Unable to Install Pyside6 on Orin

I’ve been attempting to install Pyside6 onto the Orin for a personal project but I know there’s a lack of support. I tried going through Python and Pip, repeatedly getting an issue where it says there is no Pyside6 package, so Pip can’t download it. I found out that it’s because there’s no support for it on the Orin directly, but I could install it manually by installing Qt5 and then Pyside6 through that but it’s been less than smooth. I ran into a number of errors but finally got Qt5 installed but I still can’t get Pyside setup. I’m getting a runtime error whenever I try to build setup.py in Terminal, but I haven’t found anything that’s been able to help me figure out the issue. If anybody has had a similar and been able to figure it out, please let me know!


Would you mind sharing the error you met with us?

Based on the following blog, it’s possible to build it on Linux embedded systems.
Have you checked with the library owner to see if they support the Jetson platform?



Thank you for linking the release details! The error I’m having currently is that when I run setup.py to install Pyside6, I’m met with:

Runtime Error:
setup.py invocation failed with exit code: 1.


Could you share the complete error log with us?

Well, The Pyside6 not support open source build anymore, i have try to follow thes solution and success with 5.15.6 PySide2 (Qt for python) installation on Jetson Xavier - #4 by Muscle_Oliver but for PySide6, Qt want to charge user build from source, I got this information from the readme.txt from Qt after download pyside6.4.1

Hi, I also encounter this issues. Did you have any solution ?


The log indicates some compatibility issue.
Have you checked this issue with QT team?


Me and Qt team have solved this issue:

Good to know this.
Thanks for the feedback.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.