Unable to install Tesla V100 GPU drivers

I followed the instructions given in https://www.nvidia.com/Download/driverResults.aspx/154569/en-us
however, running nvidia-smi returns following error:
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I tried almost all the installation methods given, but stuck with this error.

Processor - i9 9900KF
Motherboard- Asrock z390 Pro4
OS: Ubuntu 18.04.01
Kernel: 5.3.0-28-generic
GPU: Tesla V100 PCIe 32gb

P.S. Alternate methods I tried:

  1. https://forums.fast.ai/t/nvidia-smi-has-failed-because-it-couldnt-communicate-with-the-nvidia-driver/41557/2
  2. https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#pre-installation-actions
  3. https://docs.nvidia.com/datacenter/tesla/tesla-installation-notes/index.html#ubuntu-lts

Solved: Issue was with motherboard PCIe settings to enable “Above 4G decoding”. I think this should be specified in installation instructions for new users.