Unable to install uff-converter-tf with tensorflow 1.13.1

Environment

os - ubuntu 16.04
cuda 10.0
GeForce GTX 1050
tensorflow version 1.13.1.

Description

i wish to use tensorrt with/in the environment described above. ( i can’t upgrade cuda at this point in time)
i have a trained frozen graph ( tf version 1.13.1)
i wish to convert it to uff .
i tried using ngs container - tensorRT:19.02-py2, ( tensorrRT version 5.0.2)
but uff-converter-tf is not installed there.
i’ve tried installing with apt-get install uff-converter-tf, this fails with E: Unable to locate package uff-converter-tf

i’ve found a few similar topics, in nvidia support while opening this ticket,
they suggest executing /opt/tensorrt/python/python_setup.sh,
but this leads to installation of tensorflow-2.1.0-cp27-cp27mu-manylinux2010_x86_64.whl which is not what i need/want ( = tf version 1.13.1)
( + if I’m not mistaken, uff_converter is not supported with tf 2.X, also seen this in various ngc tensorrt containers release notes)

furthermore,
the code for installation of uff-converter-tf in python_setup.sh is :
UFF_PATH="(python -c 'import uff; print(uff.__path__[0])')" chmod +x {UFF_PATH}/bin/convert_to_uff.py
ln -sf ${UFF_PATH}/bin/convert_to_uff.py /usr/local/bin/convert-to-uff

this will fail anyway since
( i have to other hosts that have tf 1.13.1 one i built manually, another pulled from docker hub,
both of them do not have the uff package )

please advise.
Omer
:-)

Hi, UFF and Caffe Parser have been deprecated from TensorRT 7 onwards, hence request you to try ONNX parser.

Please check the below link for the same.

Thanks!

dear support,

I am not interested in using TensorRt 7.
I am interested in using TensorRt 5.0.2.
is TensorRt 5.0.2 depreccated ?

thanks,
Omer.

I found the deb file in the container itself. And installed it manually using dpkg -i.

Is there another way/method/location to find the deb files online ? ( without relying on the pre built containers)

Thanks
Omer.

Hi @omerbrandis,
Support to TRT 5 and UFF parser has been deprecated.
Hence we recommend you to try the latest TRT release with ONNX parser.

Thanks!