Unable to intall CUDA 11.1 and libnvidia-gl-455:i386 using PPA in Ubuntu 18.04

Hello,
I am not able to install the last realease of CUDA 11.1 using the method deb network and the libnvidia-gl-455:i386 (required to open steam) using PPA in Ubuntu 18.04 LTS.
I tried two methods and both result in an error.

Method 1:

  1. Install the nvidia-driver-455 (ubuntu PPA).
  2. Install the libnvidia-gl-455:i386 (ubuntu PPA).
  3. Install the CUDA 11.1 (using β€œdeb (network)” method).
    Result:
$ sudo apt install cuda
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cuda : Depends: cuda-11-1 (>= 11.1.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Method 2:

  1. Install the nvidia-driver-455 (ubuntu PPA).
  2. Install the CUDA 11.1 (using β€œdeb (network)” method).
  3. Trying to install the libnvidia-gl-455:i386 (ubuntu PPA) produces uninstalling CUDA 11.1 packages.

Is there a way to have both packages installed?

Edit:

After some tries, I finally made all work using β€œrunfile (local)” method.

Method 3 (NON PPA):

sudo apt-get --purge remove "*cublas*" "*cufft*" "*curand*"  "*cusolver*" "*cusparse*" "*npp*" "*nvjpeg*" "cuda*" "nsight*"
sudo apt-get --purge remove "*nvidia*"
sudo reboot
wget https://developer.download.nvidia.com/compute/cuda/11.1.0/local_installers/cuda_11.1.0_455.23.05_linux.run
sudo sh cuda_11.1.0_455.23.05_linux.run

Is there a way to have both packages installed toguether using PPA?

2 Likes

I’m in the same boat. Ubuntu 20.04 x64, Cuda for work, Steam for run. Would really like to have both installed without having to bypass the package manager.

Thanks, Method 3 (NON PPA) worked for me. It’s great that turning off GDM was not mandatory for installing graphics driver, as for some reason every time I turned it off my keyboard started mapping characters wrong.

It happened to me in some installation tries. This issue and another, that is the second monitor is not detected automatically, are both fixed by rebooting the system.

The Method 3 does not work in Ubuntu 20.10, I guess I need to modify the script in some way, just not sure how.