Unable to locate package nvidia-l4t-rt-kernel and nvidia-l4t-rt-kernel-headers

I have updated the Jetson AGX kit to r35.1 after editing this configuration:

vi /etc/apt/sources.list.d/nvidia-l4t-apt-source.list

But when I tried to install the real-time kernel package, I ended up with this error:

$ sudo apt install nvidia-l4t-rt-kernel nvidia-l4t-rt-kernel-headers

Reading package lists… Done

Building dependency tree

Reading state information… Done

E: Unable to locate package nvidia-l4t-rt-kernel

E: Unable to locate package nvidia-l4t-rt-kernel-headers

Is any solution or workaround for that?

Thanks in advance.
donghai

There seems to be some issue at sever, we’re fixing it, please use the source package instead for now. Thanks

Please find the RT sources from the L4T Driver Package (BSP) Sources

Could you please give us a timeline when the compiled headers are going to be available?

1 Like

I’m trying to figure this out now. It says in the release notes that the realtime kernel is supported in this release. Almost like it is trying to say that it is the the default kernel, though the notes also say that it is a developer preview. What is the current status of this? If I want to use it I need to build it?

I am little confused now.
So what should we do with using rt-patch in Jetson Linux?
I just tried the repo listed in 35.1 developer guide, but failed with not finding the rt-kernel stuffs.

So is it to say I have to compile the rt-kernel from source code?
And if so, how can I update/install the self-built kernel in Jetson?
Thanks

Yes I come up with the same problem, I updated my jetson AGX Xavier to L4T 35.1 recently, but unable to locate the nvidia-l4t-rt-kernel. Is the patch not ready yet ? Is there a timeline when it is going to be available

Is there any solution for this?

I cannot download the packages using the ‘apt’ command.

Building from source does not appear to generate the rt-kernel files.

Is the real-time kernel capability actually ready and available for 35.1 ?