Unable to login through SDK Manager

Same with me!

There is also a unusual behaviour, when I try to log into developer.nvidia.com:
The direct login fails (same error message: incorrect email or password).
If I click on “CREATE AN ACCOUNT”, the next page let’s me choose an existing account and then - suddenly - I am logged into the developer space.

If the actual packages like Jetpack 4.2.1 could be downloaded separately, I could use the offline-mode of the sdkmanager. But I don’t find any download link.

We have found the problem and addressed the issue. Let me know if you have any issues logging into the SDK manager.

NVIDIA SDK Manager was working fine on Friday 07/26, I was able to install it. But for the past couple of days, I am getting either “Incorrect email or password” or “Data received is invalid” error for "NVIDIA DEVELOPER - developer.nvidia.com’ login dialog. Because of repeated attempts, it even blocked login from my host machine, but received a email message, when I followed the link in email, I was able to unblock my IP address. Unblocking did not help, I saw the same error, so I decided to change the password. Changing the password did not help either. I tried the “sdkmanager --spectron --ignore-certificate-errors” command as well, it is still not working. I cannot login into developer.nvidia.com site using my email/password on my first attempt, but it gives me an option to login via the loginID button it shows.

Hi Sheetalg,

I have forwarded this on to the team for a look. I will keep you posted.


I am still experiencing the issue being described by peter.muenstermann and sheetalg.

I can login to https://www.nvidia.com/en-us/account/ and view my account, but I cannot login properly to developer.nvidia.com. If I visit developer.nvidia.com I am given an option to select my username and I am then logged in, but logging in @ https://developer.nvidia.com with username and password fails. I am also unable to
login to the sdkmanager. In both cases, I receive the same error “Login failed: Incorrect email or password”

My credentials must be correct, that is how I am able to login to the forums. Something seems to be wrong with the login mechanism for these properties.

@toolboc, @sheetalg,

You should now be able to log in like you normally would.

Let me know if you have any problems.



I can confirm that I am no longer experiencing the issue.



Hi Paul,

Thanks for confirming.


I also succeed morning. However, after 3 hours, it failed again when I try to re-open.

I fixed it, it is my network issue.

Hello! I seem to not be able to log in on SDK manager with my devloper.nvidia.com account. I keep getting a “Incorrect email or password”, despite having earlier reset my password.

Is anyone able to guide me through this?


Nvidia responded pretty quickly to this last time. As a work around I created a new account and logged in and that fixed it for me and I reverted to my original account a day later.


Hi Joyce,

I have someone looking into your account now. Stay tuned.


Hi Joyce,

I don’t see anything wrong with your account on the developer side. Can you please verify that you’re on the right login tab on SDK Manager?


I’m having the same problem. I can access to my account on website but I get “Incorrect email or password” when I try login SDK Manager. I tried to change my password but the result is the same.

Please, could you help me?


could not login from sdk manager. Forgot password is sending me a link which is not redirecting to a reset password page.


We are looking into this issue now. Stay tuned for updates.


Hello @raghu51nz2 & @cpaniagua,

We have not found any issues with the SDK Manager at this time. Can you please provide the ~/.nvsdkm/sdkm.log to help us troubleshoot?


We discovered an issue with your IP being blocked. You should be good to go now.


I have the same problem on the SDK manager. It looks like my IP was blocked and I did “unblock” the IP from the link provided in email. However after many hours, it looks like it still is giving me a response of Incorrect email or password.