Unable to run deepstream_python_app #1

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) Jetson nano
• DeepStream Version 5.0.0
• JetPack Version (valid for Jetson only) 4.4
• TensorRT Version 7.1.3.0
• NVIDIA GPU Driver Version (valid for GPU only)
Hi,
I’m using Jetson nano to run deepstream_python_apps. I tried to run deepstream-test1 by entering

$ python3 deepstream_test_1.py …/…/…/…/samples/streams/sample_1080p_h264.mp4

Then I got a gst-stream-error-quark as below:
case_1.txt (1.7 KB)

When I tried to use another sample video as

$ python3 deepstream_test_1.py …/…/…/…/samples/streams/sample_720p.mp4

It stopped at “NvMMLiteBlockCreate : Block : BlockType = 261” and froze.
case_2.txt (1.7 KB)

Plaese check my attachments to help. Thanks.
cfg_n_python.zip (5.5 KB)

test 1 sample only accept H264 elementary stream, you may refer to test3 sample which use uridecodebin so that any type of input (e.g. RTSP/File), any GStreamer supported container format, and any codec can be used as input.

Hi,
Thanks for your reply. I ran the test3 and got the error message as

Traceback (most recent call last):
File “deepstream_test_3.py”, line 85, in tiler_src_pad_buffer_probe
frame_meta = pyds.NvDsFrameMeta.cast(l_frame.data)
AttributeError: type object ‘bindings.jetson.pyds.NvDsFrameMeta’ has no attribute ‘cast’

I’ve already put the bindings directory in /deepstream-test3 and added from bindings.jetson import pyds for it.

Also, when it’s running, a new window popped up but didn’t display the video in it. Please check my attachments. Thanks.
files.zip (3.0 MB)

Did you do this,
The sample applications gets the import path for this module through common/utils.py. A setup.py is also included for installing the module into standard path:
cd /opt/nvidia/deepstream/deepstream/lib
python3 setup.py install