Unable to run deepstream_test_1_usb.py

**• Hardware Platform (igx aarch64)
**• DeepStream Version 6.4
**• Issue Type question

Trying to run the python scripts in

I followed deepstream_python_apps/bindings/README.md at master · NVIDIA-AI-IOT/deepstream_python_apps · GitHub


cd deepstream_python_apps/apps/deepstream-test1-usbcam
python3 deepstream_test_1_usb.py /dev/video1


Creating Pipeline

Creating Source

Creating Video Converter

 Unable to create NvStreamMux
 Unable to create pgie
 Unable to create nvosd
Creating nv3dsink

 Unable to create nv3dsink
Playing cam /dev/video0
Traceback (most recent call last):
  File "/opt/nvidia/deepstream/deepstream-6.4/sources/deepstream_python_apps/apps/deepstream-test1-usbcam/deepstream_test_1_usb.py", line 280, in <module>
  File "/opt/nvidia/deepstream/deepstream-6.4/sources/deepstream_python_apps/apps/deepstream-test1-usbcam/deepstream_test_1_usb.py", line 213, in main
    streammux.set_property('width', 1920)
AttributeError: 'NoneType' object has no attribute 'set_property'

Have you installed DeepStream SDK? python binding is only wrap the native sdk, you need to install Deepstream SDK first

Is this a GPU or a jetson? It is recommended that you use docker

Using docker, installed DeepStream 6.4 , its a dGPU

Does the following command have any results?

gst-inspect-1.0 nvstreammux

Which docker do you use and what is your command to start docker?

try the following script .


Docker image I am using 6.4-samples-multiarch
inspect returns : No such element or plugin 'nvstreammux'
also tried install.sh nothing changed

Please use the docker image below. The 6.4-samples-multiarch can only be used for display and does not include related header files.


same problem while running this, also running command is:

docker run -it --rm --net=host --runtime nvidia --device=/dev/video0  -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-6.4 -v /tmp/.X11-unix/:/tmp/.X11-unix nvcr.io/nvidia/deepstream:6.4-triton-multiarch

still No such element or plugin 'nvstreammux'

also tried C app samples in
which almost same thing is missing. This line is triggered :

  if (!pipeline || !streammux) {
    g_printerr ("One element could not be created. Exiting.\n");
    return -1;

streammux issue again

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

If your device is a dGPU, the correct command should be the following.

There are some subtle differences between dGPU and Jetson,This will affect the operation of deepstream

docker run --gpus all -it --rm --net=host --privileged -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-6.4 deepstream:6.4-triton-multiarch

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.