Fail to run

I got a jetson orin nano, here is my enviroment:
CUDA: 11.4.315
VPI: 2.2.7
OpenCV: 4.5.4
L4T: 35.3.1
Jetpack: 5.1.1
Deepstream: 6.2
Python: 3.8.10

I try to run with:
sudo python3 0_xxxx.h264

And I got this:

Creating Pipeline 
Creating Source 
Creating H264Parser 

Creating Decoder 

 Unable to create NvStreamMux 
 Unable to create pgie 
Creating nv3dsink 

Playing file /home/mic-711on/nvVideo/0_20231109195000.h264 
Traceback (most recent call last):
  File "", line 258, in <module>
  File "", line 196, in main
    streammux.set_property('width', 1920)
AttributeError: 'NoneType' object has no attribute 'set_property'

I already set USE_NEW_NVSTREAMMUX=“yes”, but it did not help.

Because you don’t have deepstream’s python bindings installed,
You can try this installation script, here is the code link

Considering you are using DS-6.2, you should use tag 1.1.6

Thanks, Junshengy, I will try it soon.

Hi, me again.
I built the pyds 1.1.6 follow this
and the same error came up. Maybe my build process is bad?

here is my build process
build_process.txt (30.1 KB)

Your compilation is fine, but you don’t seem to have it installed?

 pip3 install pyds-1.1.6-py3-none-linux_x86_64.whl

The script I mentioned in my last reply can avoid tedious compilation if you use it like the following

./ -v 1.1.6


./ -b -r master

Hi, junshengy.
I had used the pip install command, and I checked it by pip3 list, and import pyds in python3.8.10. Maybe the Deepstream SDK is not installed correctly? Cuda and other drivers seems fine, I have tried some DL code and decode video with NVDEC. They worked well. So I didn’t install Deepstream through SDK manager. Perhaps that is reason?

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

Try run the script in /opt/nvidia/deepstream/deepstream.

If it still doesn’t work, you can try use the sdkmanger to reflash

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.