Unable to run two gstreamer/deepstream pipelines that accept same camera input at the same time

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) Jetson Xavier
• DeepStream Version 5.0.1
• JetPack Version (valid for Jetson only) 4.5
• TensorRT Version come with Jetpack
• Issue Type( questions, new requirements, bugs) questions
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)


I am trying to create two pipelines in different processes.
So I tried to run the python examples: deepstream_imagedata-multistream.py in two different terminals at the same time, the first terminal works fine alone but gives me the error when i tried to run it in a second terminal:

Error: gst-stream-error-quark: Internal data stream error. (1): gstbasesrc.c(3055): gst_base_src_loop (): /GstPipeline:pipeline0/GstBin:source-bin-01/GstURIDecodeBin:uri-decode-bin/GstRTSPSrc:source/GstUDPSrc:udpsrc3:
streaming stopped, reason not-linked (-1)

The command i use are like:
python deepstream_imagedata-multistream.py rtsp:camera1 rtsp:camera2 (in terminal 1)
python deepstream_imagedata-multistream.py rtsp:camera1 rtsp:camera2 (in terminal 2)

I would assume this is related to the camera source bin issue that can be fixed in code?
How do I create two different pipeline that accept the same camera/cameras?

I can run:
deepstream_imagedata-multistream.py rtsp:camera1 rtsp:camera1 rtsp:camera2 rtsp:camera2
to accept same camera input but it would be in the same process and in one pipeline.


I can not reproduce your error in my device.

May i ask what spec are you using?

I try the opencv to open the same rtsp camera in two process, it works fine.

But when I run one of the deepstream app (like test 3 with the rtsp camera), and if i run another opencv capture the same rtsp camera, the deepstream app will crash and produce the above source error.

I am doing the test on Jetson Xavier NX.

I test the case with Xavier NX. It can not be reproduced.

It is related to gstreamer I think, cause I tried both the jetson-inference and deepstream, when I access the same rtsp camera with two individual processes, one of them will crash…