Unknow Error, first installation/utilisation of Cuda


first of all sorry for my English…

I have to work on a project that isn’t mine, and tried to install all the packages that I need to run it properly.
However, when executing it and Opening some file that need Cuda, I’ve got this “Cuda Error: unknown error returned from cudaGetDeviceCount.” error message.

I don’t really know what’s happening. I’m pretty new to all of this and don’t know if I messed up something in the installation process… I installed the nvidia toolkit package and that’s pretty all I’ve done.

I’m running on ubuntu and have a Geforce GTX 950M, driver 352.63. I’m running the project with qtcreator. (pretty sure it can’t help, but well…)

Could somebody try to help me ?
Thank you very much for reading ! Let me know if I forgot any informations that might help…

Hi InserSuppr,

Which version of Ubuntu?

Did you follow the steps on the installation guide?

Did you blacklist Nouveau & regen initramfs?

These installations can be finicky, and if you are new to Linux, it can be daunting.


Thank you for your answer !

Well, In fact I just tried to use sudo and it worked… so well, don’t really now where the problem comes from.

Anyway, thank you again :)