Unstable high and low levels when the GPIO of TX2 NX accepts signals from the infrared sensor

I want to read the output signal of the IR sensor using the GPIO of TX2 NX, but the level signal read is very unstable. The operating voltage of the IR sensor I am using is 10V and 5V, and I have tried pull_up_down operation but it does not improve the situation. Is the operating voltage of the sensor too high, or is the TX2 NX unable to control the pull-up/down?

hello 776396903,

may I know which GPIO pin you’re controlling?
please also share the Jetpack release version you’re working with.

I tried to control the GPIO12, the Jetpack version is 4.6.3 and the sensor is operating at DC 5V.
My guess is that the operating voltage may be too high, so I am going to try by sourcing a sensor with a lower operating voltage. Do you have any other better suggestions?

Hi, GPIO12 is 3.3V level, can’t be used for 5V/12V signal capture.

Thanks, i have sourcing some sensors with 3.3V level.

I tried the sensor with an operating voltage of 3.3V and the GPIO12 only detects a low level regardless of whether the sensor is triggered or not. The voltage is 3.3V when the sensor is not triggered and about 12mV when it is triggered. do you know what the problem is

Please check your sensor pin output level. If GPIO12 is 3.3v without sensor, then it was pulled low by sensor.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.