Upgraded to Jetpack 4.6 on 5 Jetson Nanos 2 GB, now 4 won't boot

So I upgraded the 5 jetson nano 2 gb I had in a cluster last week, and now 4 out of the 5 won’t boot. The green light comes on and that is it.

So I connected with serial console and all four show the following.

" Welcome to minicom 2.7.1

OPTIONS: I18n

Compiled on Dec 23 2019, 02:06:26.

Port /dev/ttyUSB0, 20:40:59

Press CTRL-A Z for help on special keys

[0000.125] [L4T TegraBoot] (version 00.00.2018.01-l4t-dd84d362)

[0000.130] Processing in cold boot mode Bootloader 2

[0000.135] A02 Bootrom Patch rev = 1023

[0000.138] Power-up reason: pmc por

[0000.141] No Battery Present

[0000.144] pmic max77620 reset reason

[0000.147] pmic max77620 NVERC : 0x40

[0000.151] RamCode = 1

[0000.153] Platform has DDR4 type RAM

[0000.156] max77620 disabling SD1 Remote Sense

[0000.161] Setting DDR voltage to 1125mv

[0000.165] Serial Number of Pmic Max77663: 0x241aea

[0000.172] Entering ramdump check

[0000.175] Get RamDumpCarveOut = 0x0

[0000.179] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8

[0000.184] Last reboot was clean, booting normally!

[0000.188] Sdram initialization is successful

[0000.192] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000

[0000.199] Lp0 Carveout Base=0x00000000ff800000 Size=0x00000000

[0000.204] BpmpFw Carveout Base=0x00000000ff800000 Size=0x00000000

[0000.210] GSC1 Carveout Base=0x00000000ff800000 Size=0x00000000

[0000.216] Resize the SecureOs Carveout to 0x00100000

[0000.221] GSC2 Carveout Base=0x00000000ff900000 Size=0x00100000

[0000.227] GSC4 Carveout Base=0x00000000ff800000 Size=0x00000000

[0000.232] GSC5 Carveout Base=0x00000000ff800000 Size=0x00000000

[0000.238] GSC3 Carveout Base=0x00000000bf800000 Size=0x00200000

[0000.244] RamDump Carveout Base=0x0000000000000000 Size=0x00000000

[0000.250] Platform-DebugCarveout: 0

[0000.253] Nck Carveout Base=0x00000000ff800000 Size=0x00000000

[0000.259] Non secure mode, and RB not enabled.

[0000.263] BoardID = 3448, SKU = 0x3

[0000.266] QSPI-ONLY: SkipQspiOnlyFlag = 0

[0000.270] Nano-SD: checking PT table on QSPI …

[0000.274] Read PT from (2:0)

[0000.290] Using BFS PT to query partitions

[0000.296] Loading Tboot-CPU binary

[0000.324] Verifying TBC in OdmNonSecureSBK mode

[0000.334] Bootloader load address is 0xa0000000, entry address is 0xa0000258

[0000.341] Bootloader downloaded successfully.

[0000.345] Downloaded Tboot-CPU binary to 0xa0000258

[0000.350] MAX77620_GPIO5 configured

[0000.353] CPU power rail is up

[0000.356] CPU clock enabled

[0000.360] Performing RAM repair

[0000.363] Updating A64 Warmreset Address to 0xa00002e9

[0000.368] BoardID = 3448, SKU = 0x3

[0000.371] QSPI-ONLY: SkipQspiOnlyFlag = 0

[0000.375] Nano-SD: checking PT table on QSPI …

[0000.379] Loading NvTbootBootloaderDTB

[0000.446] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode

[0000.515] Bootloader DTB Load Address: 0x83000000

[0000.520] BoardID = 3448, SKU = 0x3

[0000.523] QSPI-ONLY: SkipQspiOnlyFlag = 0

[0000.527] Nano-SD: checking PT table on QSPI …

[0000.531] Loading NvTbootKernelDTB

[0000.597] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode

[0000.677] Kernel DTB Load Address: 0x83100000

[0000.681] BoardID = 3448, SKU = 0x3

[0000.684] QSPI-ONLY: SkipQspiOnlyFlag = 0

[0000.688] Nano-SD: checking PT table on QSPI …

[0000.694] Loading cboot binary

[0000.810] Verifying EBT in OdmNonSecureSBK mode

[0000.852] Bootloader is corrupted!

[0000.855] Error in NvTbootLoadBinary: 0x14 !

[0000.859] BoardID = 3448, SKU = 0x3

[0000.862] QSPI-ONLY: SkipQspiOnlyFlag = 0

[0000.866] Nano-SD: checking PT table on QSPI …

[0000.871] PT: Partition RBL NOT found !

[0000.874] Warning: Find Partition via PT Failed

[0000.879] Error is 1

[0000.117] [L4T TegraBoot] (version 00.00.2018.01-l4t-dd84d362)

[0000.123] Processing in cold boot mode Bootloader 2

[0000.127] A02 Bootrom Patch rev = 1023

[0000.131] Power-up reason: pmc por

[0000.134] No Battery Present

[0000.137] pmic max77620 reset reason

[0000.140] pmic max77620 NVERC : 0x40

[0000.144] RamCode = 1

[0000.146] Platform has DDR4 type RAM

[0000.149] max77620 disabling SD1 Remote Sense

[0000.153] Setting DDR voltage to 1125mv

[0000.157] Serial Number of Pmic Max77663: 0x241aea

[0000.165] Entering ramdump check

[0000.168] Get RamDumpCarveOut = 0x0

[0000.171] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8

[0000.176] Last reboot was clean, booting normally!

[0000.181] Sdram initialization is successful

[0000.185] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000

[0000.191] Lp0 Carveout Base=0x00000000ff800000 Size=0x00000000

[0000.197] BpmpFw Carveout Base=0x00000000ff800000 Size=0x00000000

[0000.203] GSC1 Carveout Base=0x00000000ff800000 Size=0x00000000

[0000.209] Resize the SecureOs Carveout to 0x00100000

[0000.213] GSC2 Carveout Base=0x00000000ff900000 Size=0x00100000

[0000.219] GSC4 Carveout Base=0x00000000ff800000 Size=0x00000000

[0000.225] GSC5 Carveout Base=0x00000000ff800000 Size=0x00000000

[0000.231] GSC3 Carveout Base=0x00000000bf800000 Size=0x00200000

[0000.237] RamDump Carveout Base=0x0000000000000000 Size=0x00000000

[0000.242] Platform-DebugCarveout: 0

[0000.246] Nck Carveout Base=0x00000000ff800000 Size=0x00000000

[0000.251] Non secure mode, and RB not enabled.

[0000.256] BoardID = 3448, SKU = 0x3

[0000.259] QSPI-ONLY: SkipQspiOnlyFlag = 0

[0000.263] Nano-SD: checking PT table on QSPI …

[0000.267] Read PT from (2:0)

[0000.283] Using BFS PT to query partitions

[0000.288] Loading Tboot-CPU binary

[0000.317] Verifying TBC in OdmNonSecureSBK mode

[0000.327] Bootloader load address is 0xa0000000, entry address is 0xa0000258

[0000.334] Bootloader downloaded successfully.

[0000.338] Downloaded Tboot-CPU binary to 0xa0000258

[0000.343] MAX77620_GPIO5 configured

[0000.346] CPU power rail is up

[0000.349] CPU clock enabled

[0000.353] Performing RAM repair

[0000.356] Updating A64 Warmreset Address to 0xa00002e9

[0000.361] BoardID = 3448, SKU = 0x3

[0000.364] QSPI-ONLY: SkipQspiOnlyFlag = 0

[0000.368] Nano-SD: checking PT table on QSPI …

[0000.372] Loading NvTbootBootloaderDTB

[0000.438] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode

[0000.508] Bootloader DTB Load Address: 0x83000000

[0000.512] BoardID = 3448, SKU = 0x3

[0000.516] QSPI-ONLY: SkipQspiOnlyFlag = 0

[0000.519] Nano-SD: checking PT table on QSPI …

[0000.524] Loading NvTbootKernelDTB

[0000.590] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode

[0000.669] Kernel DTB Load Address: 0x83100000

[0000.674] BoardID = 3448, SKU = 0x3

[0000.677] QSPI-ONLY: SkipQspiOnlyFlag = 0

[0000.681] Nano-SD: checking PT table on QSPI …

[0000.687] Loading cboot binary

[0000.803] Verifying EBT in OdmNonSecureSBK mode

[0000.844] Bootloader is corrupted!

[0000.848] Error in NvTbootLoadBinary: 0x14 !

[0000.852] BoardID = 3448, SKU = 0x3

[0000.855] QSPI-ONLY: SkipQspiOnlyFlag = 0

[0000.859] Nano-SD: checking PT table on QSPI …

[0000.863] PT: Partition RBL NOT found !

[0000.867] Warning: Find Partition via PT Failed

[0000.871] Error is 1

CTRL-A Z for help | 115200 8N1 | NOR | Minicom 2.7.1 | VT102 | Online 0:1 | ttyUSB0"

Any idea on how to remedy?
And I have tried reflashing new SD cards same result so I believe this may be an onboard software/code issue.

Flashing sdcard does not help. You need to flash the QSPI on the board.

Only sdkmanager is able to do that. Sdcard image cannot save such situation.

Ok so i have sdk manager running on ubuntu 18 laptop and have serial console up and runnng and have micro usb plugged into the jetson but it does not recognize the device

is there a credible tutorial on the process for a nano?

Put the board into recovery mode manually. Follow the quick start guide to know how to do that.

The flash can only happen when it is in recovery mode (RCM).

I want to thank you. You helped me grow as a person, student, scientist. I appreciate you greatly!!!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.