Jetson nano fails to boot with new 4.6 Jetpack image

I recently tried updating jetpack from 4.5 to 4.6 but when I put in the SD card and boot up Jetson nano. It simply blinks the green light once and that’s it. Nothing comes on again, I’m confused at what happened since I’m currently using the barrel jack.

I need urgent assistance please

1 Like

hello bvgohmslf,

we have Nano flashed with JetPack-4.6 and it works normally.
could you please setup serial console and gather the complete bootloader messages for reference,
thanks

Here is what I get

Welcome to minicom 2.7.1

OPTIONS: I18n 
Compiled on Dec 23 2019, 02:06:26.
Port /dev/ttyUSB0, 10:32:22

Press CTRL-A Z for help on special keys

[0000.125] [L4T TegraBoot] (version 00.00.2018.01-l4t-dd84d362)
[0000.130] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.138] Power-up reason: pmc por
[0000.141] No Battery Present
[0000.144] pmic max77620 reset reason
[0000.147] pmic max77620 NVERC : 0x40
[0000.151] RamCode = 0
[0000.153] Platform has DDR4 type RAM
[0000.156] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number f Pmic Max77663: 0x2204ad
[0000.172] Entering ramdump check
[0000.175] Get RamDumpCarveOut = 0x0
[0000.179] RamDumpCarveOut=0x0,  RamDumperFlag=0xe59ff3f8                     
[0000.184] Last reboot was clean, booting normally!                           
[0000.188] Sdram initialization is successful                                 
[0000.192] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000          
[0000.199] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000               
[0000.204] BpmpFw Carveut Base=0x00000000ff700000 Size=0x00080000             
[0000.210] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000              
[0000.216] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000              
[0000.222] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000              
[0000.228] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000              
[0000.234] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000              
[0000.250] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000           
[0000.256] Platform-DebugCarveout: 0                                          
[0000.259] Nck Carveout Base=0x00000000ff080000 Size=0x00200000               
[0000.265] Non secure mode, and RB not enabled.                               
[0000.269] BoardID = 3448, SKU = 0x0                                          
[0000.272] QSPI-ONLY: SkipQspiOnlyFlag = 0                                    
[0000.276] Nano-SD: checking PT table on QSPI ...                             
[0000.281] Read PT from (2:0)                                                 
[0000.296] Using BFS PT to query partitions                                   
[0000.302] Loading Tboot-CPU binary                                           
[0000.330] Verifying TBC in OdmNonSecureSBK mode                              
[0000.340] Bootloader load address is 0xa0000000, entry address is 0xa0000258 
[0000.347] Bootloader downloaded successfully.                                
[0000.351] Downloaded Tboot-CPU binary to 0xa0000258                          
[0000.356] MAX77620_GPIO5 configured                                          
[0000.359] CPU power rail is up                                               
[0000.362] CPU clock enabled                                                  
[0000.366] Performing RAM repair                                              
[0000.369] Updating A64 Warmreset Address to 0xa00002e9                       
[0000.374] BoardID = 3448, SKU = 0x0                                          
[0000.377] QSPI-ONLY: SkipQspiOnlyFlag = 0                                    
[0000.381] Nano-SD: checking PT table on QSPI ...                             
[0000.385] Loading NvTbootBootloaderDTB                                       
[0000.452] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode             
[0000.523] Bootloader DTB Load Address: 0x83000000                            
[0000.528] BoardID = 3448, SKU = 0x0                                          
[0000.531] QSPI-ONLY: SkipQspiOnlyFlag = 0                                    
[0000.535] Nano-SD: checking PT table on QSPI ...                             
[0000.540] Lading NvTbootKernelDTB                                            
[0000.606] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode                 
[0000.679] Kernel DTB Load Address: 0x83100000                                
[0000.683] BoardID = 3448, SKU = 0x0                                          
[0000.686] QSPI-ONLY: SkipQspiOnlyFlag = 0                                    
[0000.690] Nano-SD: checking PT table on QSPI ...                             
[0000.696] Loading cboot binary                                               
[0000.812] Verifying EBT in OdmNonSecureSBK mode                              
[0000.854] Bootloader load address is 0x92c00000, entry address is 0x92c00258 
[0000.861] Bootloader downloaded successfully.                                
[0000.865] BoardID = 3448, SKU = 0x0                                          
[0000.868] QSPI-ONLY: SkipQspiOnlyFlag = 0                                    
[0000.872] Nano-SD: checking PT table on QSPI ...                             
[0000.876] PT: Partition NCT NOT found !                                      
[0000.880] Warning: Find Partition via PT Failed                              
[0000.884] Next binary entry address: 0x92c00258                              
[0000.889] BoardId: 3448                                                      
[0000.893] Overriding pmu board id with proc board id                         
[0000.898] Display board id is not available                                  
[0000.903] BoardID = 3448, SKU = 0x0                                          
[0000.906] QSPI-ONLY: SkipQspiOnlyFlag = 0                                    
[0000.910] Nano-SD: checking PT table on QSPI ...                             
[0001.015] Verifying SC7EntryFw in OdmNonSecureSBK mode                       
[0001.071] /bpmp deleted                                                      
[0001.073] SC7EntryFw header found loaded at 0xff700000                       
[0001.269] OVR2 PMIC                                                          
[0001.271] Bpmp FW successfully loaded                                        
[0001.274] BoardID = 3448, SKU = 0x0                                          
[0001.278] QSPI-ONLY: SkipQspiOnlyFlag = 0                                    
[0001.281] Nano-SD: checking PT table on QSPI ...                             
[0001.287] WB0 init successfully at 0xff780000                                
[0001.291] Set NvDecSticky Bits                                               
[0001.295] GSC2 address ff53fffc value c0edbbcc                               
[0001.301] G/C MC Settings done                                               
[0001.304] BoardID = 3448, SKU = 0x0                                          
[0001.307] QSPI-ONLY: SkipQspiOnlyFlag = 0                                    
[0001.311] Nano-SD: checking PT table on QSPI ...                             
[0001.316] TOS Image length 53680                                             
[0001.319]  Monitor size 53680                                                
[0001.322]  OS size 0                                                         
[0001.337] Secure Os Aes-CMAC Verification Failed!                            
[0001.342] Error in NvTbootValidateTOS [11]                                   
[0001.346] Validation of secure os failed!                                    
[0001.349] Device Shutdown called ... 

What might be the issue

if by chance this is the issue …2x Jetson Nanos turn on with Green Light but no HDMI output - with Log Files

Can I use ubuntu 20.4 to run the sdk manager and if not how I can I dual boot 20.04 and 18.04 on my laptop, a link will be helpful here. Thanks

1 Like

hello bvgohmslf,

is this SD card format before? please refer to Getting Started With Jetson Nano Developer Kit | NVIDIA Developer and use the tools to format the card.

I’ve resolved the issue. Thanks