Upgrading From TRT 7.2.2 to TRT 8.4.1

Upgrading From TRT 7.2.2 to TRT 8.4.1

I am trying to upgrade from TensoRT 7.2.2 into TensorRT 8.4.1
I have installed the prerequisites as stated in the Nvidia installation guide, and Iwas able to compile the code after multiple changes and adaption of the code due to use of removed functionality.
However, it has a run time error which is quite weird, when I try to create an instance of IBuilder using the createInferBuilder function(which isn’t found the documentation of TRT 8.4.1 but found in the documentation of TRT7, but still compiles without any problems)
I face the following error:

which after some debugging I have found out that it’s due to the fact that the IBuilder which is create using the createInferBuilder has the protected variable “mImpl” set to NULL.
I have tried upgrading the Cuda version from 11.1.2 to 11.6.1(because it was treated in the installation guide as the correct version, I could be wrong) but with no succes, moreover I tried using the Logger which is passed to the createInferBuilder but it didn’t log anything regarding the builder.
I have tried searching in the internet but didn’t find anything regarding such problem.
Iwould be very thankful if anyone suggests a way to solve such weird bug.

Best Regards

VS 2019
TensorRT 8.4.1
Nvidia A2
Cuda 11.6.2
CudNN 8.4.1
Windows Server 2016

Please refer to the installation steps from the below link if in case you are missing on anything

Also, we suggest you to use TRT NGC containers to avoid any system dependency related issues.


I believe that there is nothing missing from the installation steps, due to the fact that I am able to compile the code, and because I have gone over it several times to make sure that it has been done correctly.

I would be happy to know if there is something that I am using incorrectly, in order to cause such error.
Best Regards


Could you please share with us output error logs and if possible minimal issue repro model/script for better debugging.

Thank you.


Unfortunately I cant share the script/model, however here are the output error logs:

SymInit: Symbol-SearchPath: ‘.;C:\bcrepo\main\Release;C:\bcrepo\main\Release;C:\Windows;C:\Windows\system32;SRVC:\websymbolshttp://msdl.microsoft.com/download/symbols;’, symOptions: 530, UserName: ‘Administrator’

OS-Version: 6.2.9200 () 0x110-0x3

what is weird that the logger which is passed to “createinferBuilder” isn’t indicating a faulty engine building.


Which method of installation are you following?
Have you done the following up on upgrading/new installation?

After unzipping the new version of TensorRT you will need to either update the PATH environment variable to point to the new install location or copy the DLL files to the location where you previously installed the TensorRT libraries.