Use Tegra Combined Uart as regular serial on Orin NX

Hello,
we are trying to use the serial interface UART2/UC3/ttyTCU0 as multiple posts in this forum.

We base our work on this thread, and we achieve the exactly same results but using an Nvidia Orin Devkit.

We are using the SDK 36.2 and this is the fragment where we disable the combined uart:

	serial {
		compatible = "nvidia,tegra234-tcu\0nvidia,tegra194-tcu";
		status = "disabled";
		phandle = <0x229>;
		mboxes = <0x10b 0x01 0x00 0x12d 0x01 0x80000001>;
		mbox-names = "rx\0tx";
	};

Here is the fragment where we enable the serial port serial@c280000:

aliases {
...
serial3 = "/bus@0/serial@c280000";
...
}
...
                serial@c280000 {
                        clock-names = "serial";
                        resets = <0x03 0x66>;
                        interrupts = <0x00 0x72 0x04>;
                        clocks = <0x03 0x9d>;
                        compatible = "nvidia,tegra20-uart";
                        status = "okay";
                        reg = <0x00 0xc280000 0x00 0x10000>;
                        reset-names = "serial";
                };

We managed to get the serial device present, dmesg:

sudo dmesg | grep 0xc28
[    3.740130] c280000.serial: ttyS3 at MMIO 0xc280000 (irq = 71, base_baud = 114285) is a Tegra

We have tested the serial port with echo, minicom, etc from the PC with a serial to USB device and also sort circuit of tx<->rx on the orin.

tx is currently working as expected, but rx is not working.

We are 100% confident the electrical connections are fine because when flashing the initial jetson image the debuging serial port over /dev/ttyTCU0 is working fine, it is possible login using the serial console as expected.

Some other documentation we used for our testing:

It is also important to mention that we need to use 3 UARTs for communication with external controllers. For this reason, is mandatory for us to get this working.

We also tried to disable the TCU uart and use the debuging uart in the same uart.

The debugging UART with the following dtb and extlinux is sending the proper data over tx, but rx is again not working.

Please find attached the involved dts, extlinux and logging output:

no_tcu_dtb.dts.txt (306.0 KB)
extlinux.conf.txt (1.1 KB)
board_booting_output.txt (81.7 KB)

Hi EstebanBosse,

It seems you have referred to several topic for this use case.
You may see that we’ve not verified this officially and we don’t suggest using combined uart as normal uart.
The message output from combined UART is from several firmware and you have to disable each of them. Some firmware can not disable that just using BCT/configuration files.
In JP6.0DP(R36.2), you would also notice that we’ve removed the entry of serial@c280000 so that you tried to add it manually. That’s why we want combined uart working as it is. Without the serial console log, you will be hard to do further debug.
Currently, we don’t support this use case. If you require more UART interfaces, you can use UART expansion modules or just use AGX Orin (which has 4 UART interfaces available).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.