Userspace DVFS Governor


I’m trying to set manual frequencies for both the Carmel cluster and the iGPU.
I set the governor in


to userspace

Then I set my desired frequency in




However, the frequency inside scaling_setspeed goes back to what it was before and the GPU just flat out ignores my frequency. I have obtained possible frequencies from their respective files, so the frequencies are valid.

This used to work flawlessly on TX2. I was wondering if something has changed in AGX? Do I need to recompile the kernel to enable this?

Thank you in advance.

Ok so the problem with regards to GPU was apparently because of the rail_gate idle state.
You can force disable it by

echo 0 > /sys/devices/17000000.gv11b/railgate_enable

As for the CPU, it is working now and I have no idea why. Still investigating this but the issue is resolved. I leave this post for future references.

Thank you.