Using clone mode with two different aspect ratios

Hello Linux people. I have recently made the switch from Win7 to OpenSUSE 12.3 and liking it a lot. Only problem I am having is this:

I have my PC connected to both a 16:10 monitor and a larger 16:9 HDTV for surfing the net from my couch. In Windows I always used the Desktop resize feature to compensate for the overscan, and was always able to force a 1440x900 resolution onto the HDTV to match exactly that of my monitor (in clone mode).

After searching around the net I found this xorg.conf configuration that gives me exactly the result I am looking for:

Section "Screen"

    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-I-2: 1440x900 +0+0, HDMI-0: 1920x1080 +0+0 {viewportin=1440x900, viewportout=1824x1026+48+28}"
    Option         "TwinViewOrientation" "Clone"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
         Depth          24

However, if I only turn the TV on after Gnome3 is loaded, its view default to a Extended screen.

Also, after leaving the fullscreen mode of certain programs such as XBMC, the virtual screen size seems to expand to the native resolution of my HDTV, but with panning on both displays. When this happens, I have to either use xrandr or nvidia-settings to set the meta mode back.

I have been trying to fix this for 3 days now and it is really driving me nuts. Is this a bug or am I doing something wrong?

I just want my displays to retain their set screen size of 1440x900 whether they are turned on or off, in clone mode, and in all applications. shrugs

EDIT: forgot to mention I have a GTX460 and have tried both the latest Stable and Beta Drivers (325.08),

When GNOME 3 detects that a display is connected or disconnected, it will reconfigure the screen layout to match what it thinks the correct settings should be. It ignores the current configuration and the “metamodes” option in xorg.conf, and as far as I know, it also doesn’t support adjusting the display borders to achieve your overscan compensation.

I believe you can disable it with this command to prevent it from changing your configuration automatically:

dconf write /org/gnome/settings-daemon/plugins/xrandr/active false

Please note that this means you will have to manually reconfigure the screen if you want to extend the desktop to newly-connected monitors.