/usr/bin/ld: cannot find -lrendercheckgl Compilation error

Hi, I am trying to compile a sample project, but I got this.

/usr/bin/ld: cannot find -lrendercheckgl

I searched everywhere, cannot find any information on -lrendercheckgl.
Any help would be appreciated.

I tried a few examples,
I also got this

/usr/bin/ld: cannot find -lparamgl

I could get a few running, but I am a little surprised that almost nothing about these two packages can be found on the web. Google returned nothing for lrendercheckgl, it’s as if it doesn’t exist.
Any ideas?

Ok problem solved, I needed to make the entire thing all at once. There are extra linkings in the project makefile. Still in the document, it didn’t mention it.

I got same error during make process.
Does any one have the solution.

i got the same problem when doing “sudo make” on the simpleGL project

/usr/bin/ld: cannot find -lrendercheckgl

but i cannot understand what you meant with “I needed to make the entire thing all at once”
i hope you can help me thanks

someone knows in detail the steps?

Just go to the NVIDIA_CUDA_SDK directory and run make, don’t run it in the subdirectories and it should make all projects
The renderchekgl library is located in NVIDIA_CUDA_SDK/lib so you can manually insert a -L switch to the linker if necessary.


check your LD_LIBRARY_PATH to make sure /usr/local/cuda/lib is there, you may also want to add /usr/lib to it as well.

Then check libGL.so in /usr/lib, make sure it links to the right module.

This should fix it

thanks i just didnt see that main makefile,

now it works.

the only thing is that the “simpleGL” example runs and the ubuntu GUI starts to freeze and is difficult to close the application.

on ubuntu 9.04 64bit

had the same issue?

Yeah, I’m experiencing the same issue with all GL samples. It’s really annoying…

Tried all kinds of glut-libraries and disabling compiz to no avail.