V4L2 on Jetson TX1

Hi,

I am trying to test OV5693 in L4T on Jetson TX1.
In Video for Linux User Guide, it is stated that:

1. Apply patches on top of L4T release.
L4T R23.2 Release (1 patch)
$ git am 0001-ARM64-adding-OV5693-V4L2-on-E3326-jetson_cv.patch

However, I did not understand what to do. Should I apply this patch on the kernel source code or something else and where can I find 0001-ARM64-adding-OV5693-V4L2-on-E3326-jetson_cv.patch file?

Thank you.

Are you using the latest JetPack (2.2.1) or L4T R24.1? https://developer.nvidia.com/embedded/jetpack

If so, the kernel patch from R23 is unnecessary, and the V4L2 /dev/video0 is created by default at boot (onboard video).

If you are trying to test OV5693, these commands should work:

$ gst-launch-1.0 nvcamerasrc fpsRange="30.0 30.0" ! 'video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080, format=(string)I420, framerate=(fraction)30/1' ! \
nvvidconv flip-method=2 ! 'video/x-raw(memory:NVMM), format=(string)I420' ! fakesink silent=false -v

$ gst-launch-1.0 nvcamerasrc fpsRange="30.0 30.0" ! 'video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080, format=(string)I420, framerate=(fraction)30/1' ! \
nvtee ! nvvidconv flip-method=2 ! 'video/x-raw(memory:NVMM), format=(string)I420' ! nvoverlaysink -e

Thank you for your answer. I will flash my board into L4T R24.1. Actually, what I am trying to do is writing my own driver for an image sensor. To do so, I was following Video for Linux Guide for 24.1. However, as I understand some parts of the the guide is outdated.

I have downloaded the kernel source code. Using ov5693 driver as template I can create a module for my image sensor. Just loading this module will work fine for me or do I need some other step to follow?

Thank you.

For authoring custom V4L2 kernel driver, it’s recommended to follow the V4L2_Sensor_Driver_Programming_Guide_v4.0.pdf located in the L4T docs here: http://developer.nvidia.com/embedded/dlc/l4t-documentation-24-1

Have you solved this problem?I have the same problem,Could you tell me the method?

Please provide more detail about what your problem exactly is. And as dusty mentioned, please use the
V4L2_Sensor_Driver_Programming_Guide_v4.0.pdf for reference. We will fix the doc issue in next new release.

Even without doing anything, /dev/video0 is created. However, it does not use v4l2 framework. For old releases(r23.1 and r23.2), we need to remove nvhost_vi and install the ov5693_v4l2 modules, but for this release it is not specified. I have read about this issue in the forum and it seems still an unresolved issue.

Yes, for r24.1 release, we no longer need to do like that.
If you refer to the guide I mentioned above, NVIDIA has added some custom v4l2 ctrls, which should be compatible with the standard v4l2 framework.
Can you get the sensor stream successfully per the gst commands dusty’s suggested?

Yes, it worked.However, when I use the pipeline with v4l2src, the board crashes.

Please expect the next release, which will be coming soon. After then, I believe you can play it with v4l2src.

I hope so, thank you very much.

Hello, Is this sensor now supported? I can’t see it in the drivers directory.

hello maksym.walczak,

there’re a lots of architecture changes since you’re replied a thee years ago thread.

were you asking about ov5693 reference driver?
please access L4T Sources via Jetson Download Center, and you’ll found the reference sensor drivers as below.
$l4t-r32.2/public_sources/kernel/nvidia/drivers/media/i2c/*