L4T 24.1 - V4L2 on Jetson TX1


Could you please tell me where can I find the v4l2 patches for 24.1 release that are referenced in Tegra_Linux_Driver_Package_Documents_R24.1?

I just found the r23.1_v4l2.tgz, however I need to find for 24.1 release.

Thank you.

What problems are you facing regarding V4L2?

V4L2 works for me on L4T 24.1 without any patch.

I tried to follow these steps:

To verify the TPG
1. Remove the nvhost_vi module, an incompatible non-V4L2 VI driver used for other purposes and outside the scope of this document:
$ sudo rmmod nvhost_vi
2. Install V4L2 driver modules:
$ sudo modprobe soc_camera_platform
$ sudo modprobe tegra_camera tpg_mode=2
3. Use the yavta application to capture data (other V4L2 applications can be used, if preferred)
$ ./yavta /dev/video0 -c1 -n1 -s1280x720 -fRGB32 -Ftpg.rgba
4. Copy over tpg.rgba to host and use ImageMagick to show the picture:
$ display -size 1280x720 -depth 8 tpg.rgba

However, it gives an error:

ERROR: Module nvhost_vi is not currently loaded

Then I tried to load soc_camera_platform module without removing nvhost-vi and it could not find the soc_camera_platform module.

I think this is not an issue related to the patches as you stated.

It’s not an error if you want to follow those steps. nvhost_vi is not loaded and hence it can’t be removed using rmmod. Since your aim is to remove nvhost_vi, you should not worry about it as it’s already removed/not loaded.

Yes, you are right. However, now I have to load the soc_camera_platform module and it did not find the module.

You might not have enabled the soc_camera_platform or similar module while building the kernel. Use menuconfig to enable the relevant module first.

Thank you for answer alasin. I enabled the soc camera platform support as you said using menuconfig, but still module is not found.

Please follow the suggestion in the below commit,


There is some error in r24.1 doc, and it will be fixed in r24.2(coming soon)