v4l2 on jetson tx2 dev-kit

does jetpack 3.3 kernel images by default support v4l2 ? or we have to customize the kernel and build again

thanks

Hi,
It has v4l2 by default. We have tegra_multimedia_api samples based on v4l2.

im trying to load video driver , while insmod it is giving unknown symbols related to v4l2 api’s

where infact im able to load same driver on my host ubuntu 16.04 without any problem.

in dmesg

avc8000: Unknown symbol videobuf_streamoff (err 0)

avc8000 is driver name.

same way many v4l2 related api errors are displayed when i load

Hi,
Be default you can run tegra_multimedia_api samples and v4l2-ctl commands. For your usecase, it probably needs to enable certain packages/configs in kernel. Other users may share experience on it.

can u please tell what and all packages needs to be enabled?

I have same issue with avc8000

Hi,
It looks to be a device through PCIe interface. We don’t have the device. Maybe it requires additional drivers to enable it? We may have some other users who has successfully enable it on Jetson Nano and can share suggestion.

yes, by default kernel is not enabled with full v4l2 packages

we have to enable VIDEOBUF or VIDEOMEM related configs/packages by selecting in make menuconfig while building kernel.

but still it doesn’t solve, since in build steps it uses saame kernel headers , natively built module can not be loaded using insmod
it says “invalid format exe”.

what i did is, include the driver in kernel source code( follow steps to add driver in linux & select as module in menuconfig) on host where jetpack is installed.

then build kernel where above mentioned packages are enabled.

once flashed dev booted up, u can find .Ko file in /lib/modules/(uname -r)/kernel/drivers/(driver_folder_name)/driver_name.Ko

use insmod to load it