visionWorks Samples disappeared and directories messed up after following instructions

After following the suggested (solution)instructions from this topic:

https://devtalk.nvidia.com/default/topic/965838/unable-to-install-package-libvisionworks-nvxi-jetpack-l4t-2-1-1-32-bit-via-jetpack-2-3-/

(because I had a similar compilation error trying to compile the CameraCapture sample)
I dont seem to find the samples at all now and my directory might be messed up. What happened?Were they the wrong instructions? How do I restore the samples and the previous state?

Hi,

May I know where do you want to install Visionworks? Host or device?

Currently, please install VisionWorks directly via JetPack.
Not sure which error do you meet, please attach or share more information about the error.

Thanks.

The following table shows various directories where the VisionWorks packages are
located after installation.
________________________________________________________________________________
Package Name      : libvisionworks
Installed location: /usr/lib
Description       : Main package with pre-built shared libraries.
________________________________________________________________________________
Package Name      : libvisionworks-dev
Installed location: /usr/include
                    /usr/lib
                    /usr/lib/pkgconfig
                    /usr/share/visionworks/cmake
Description       : Development package with headers, supplementary CMake and
                    package config files.
________________________________________________________________________________
Package Name      : libvisionworks-samples
Installed location: /usr/share/visionworks/sources
Description       : Source code for samples, demos, and NVXIO.
________________________________________________________________________________
Package Name      : libvisionworks-docs
Installed location: /usr/share/visionworks/docs
Description       : Documentation package for this release of VisionWorks.
________________________________________________________________________________

I did have the complete vision works package because I had installed the jetpack package. When I tried to build one of the samples (camera capture) in the samples directory /usr/share/visionworks/sources, I got the following the errors (I dont have the exact error lines but they were undefined references to the following 3 functions):

undefined reference to nvxio::OptionHandler::string(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >*)' undefined reference to nvxio::createDefaultFrameSource(_vx_context*, std::__cxx11::basic_string<char, std::char_traits, std::allocator > const&)’
undefined reference to `nvxio::createDefaultRender(_vx_context*, std::__cxx11::basic_string<char, std::char_traits, std::allocator > const&, unsigned int, unsigned int, unsigned int, bool, bool)’

Looking up online, I cam accross some topics (like this one: https://devtalk.nvidia.com/default/topic/965838/unable-to-install-package-libvisionworks-nvxi-jetpack-l4t-2-1-1-32-bit-via-jetpack-2-3-/ ) here about these errors and in many of them these were the suggestions:

Remove nvxio lib
$ sudo apt-get remove --purge libvisionworks-nvxio libvisionworks-nvxio-dev

After installing VisionWorks
Install build dependencies:
$ sudo apt-get build-dep libvisionworks-nvxio libvisionworks-nvxio-dev

Download the source archive:
$ apt-get source libvisionworks-nvxio

Repackage nvxio
cd libvisionworks-nvxio_<visworks_ver>/ dpkg-buildpackage -j4 -b

Install newly built packages:
$ sudo dpkg -i …/libvisionworks-nvxio_<visworks_ver>.deb
…/libvisionworks-nvxio-dev
<visworks_ver>_all.deb

I followed these, and everything looked good, but it seems that the only thing I did was remove somehow the samples and reinstall the a library in the samples directory (because I did all these in the samples directory).

How can I undo somehow the above commands or bring back the samples)?

Hi,

For install sample, please try this:

$sudo add-apt-repository universe
$ sudo dpkg -i libvisionworks-repo_<visworks_ver>_<architecture>.deb
$ sudo apt-get update
$ sudo apt-get install libvisionworks-samples libvisionworks-docs

Thanks.

I am getting an error when I run the second command :

$ sudo dpkg -i libvisionworks-repo_1.5.3.71n_arm64.deb
dpkg: error processing archive libvisionworks-repo_1.5.3.71n_arm64.deb (–install):
cannot access archive: No such file or directory
Errors were encountered while processing:
libvisionworks-repo_1.5.3.71n_arm64.deb

Hi,

Please change the command to correct directory of libvisionworks-repo_1.5.3.71n_arm64.deb.
From comment #3, it should be …/libvisionworks-repo_1.5.3.71n_arm64.deb?