VLC suddenly stopped working - Jetson Xavier NX, Ubuntu 20.04, jetpack 5.0.2

Several months ago, I installed VLC on my Xavier NX build using the following commands:

sudo apt install vlc
sudo mv /usr/lib/aarch64-linux-gnu/vlc/plugins/codec/libomxil_plugin.so /usr/lib/aarch64-linux-gnu/vlc/plugins/codec/libomxil_plugin.so.old

This worked flawlessly for months. I had an automatic software update yesterday, not sure what all was updated. Now, when I run vlc, I get various forms of “main decoder error” messages depending upon the type of video. For video files with sound, the sound will still play, but the video is just a black screen.

I get the errors running “vlc” from the command terminal.

[0000ffff34c04f70] main decoder error: Codec `mp4v’ (MPEG-4 Video) is not supported.

Searching for the error message doesn’t seem to produce much. Any ideas on how to get VLC back up and running? It is frustrating because it worked well before.

System info below:

NVIDIA NVIDIA Jetson Xavier NX Developer Kit
L4T 35.1.0 [ JetPack 5.0.2 ]
Ubuntu 20.04.6 LTS
Kernel Version: 5.10.104-tegra
CUDA 11.4.239
CUDA Architecture: 7.2
OpenCV version: 4.6.0
OpenCV Cuda: YES
VPI: 2.1.6
Vulcan: 1.3.203

You can clean gstreamer cache and see if it works:

$ rm .cache/gstreamer-1.0/registry.aarch64.bin

If the issue persists, we suggest re-flash the system image. The latest release is Jetpack 5.1.1 and it’s more stable than 5.0.2

Not faced that yet.
Maybe the update reinstalled omxil plugin, did you try to disable it as before ?

I tried running:

rm ~/.cache/gstreamer-1.0/registry.aarch64.bin

There was no change. I am using a non-standard carrier board for my Xavier NX (Seeed A203 v2). I am not sure if it supports the newer jetpack.

I have reinstalled VLC. If I run it without doing the libomxil step, it just core-dumps when I try to play a video.

If I perform the command “sudo mv /usr/lib/aarch64-linux-gnu/vlc/plugins/codec/libomxil_plugin.so /usr/lib/aarch64-linux-gnu/vlc/plugins/codec/libomxil_plugin.so.old”, it doesn’t core dump, but it can’t decode video.

I used TimeShift to move back to late May. After that, VLC works again (using the same two line install, apt based, then moving the libomxil_plugin.so file.

After a ubuntu 20.04 software update (which affects gstreamer and maybe other SW), it kills VLC again in the same manner. Hopefully I will be able to figure out which software update kills VLC and block it.

I’m wondering if the VLC version changed… So far I have been using up to :

cvlc --version
VLC media player Vetinari (revision
VLC version Vetinari (


That is the same version I am running (again) now successfully. There is some update in the Ubuntu Software Updater that breaks it. I have used TimeShift to go back to the working state, and then updated with the suggested updates and broken it repeatedly. It also breaks if I apply the updates first, and then install VLC (for the “first” time on the system) afterward. Not sure exactly what the conflict is, but there are some gstreamer updates that get applied.

For now, VLC is working again, and gstreamer is working again, so I will just hold off on those updates until I can figure out the conflict.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.