VPI 1.1 installation on x86

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) GPU
• DeepStream Version 6.0
• JetPack Version (valid for Jetson only)
• TensorRT Version 8.0.1
• NVIDIA GPU Driver Version (valid for GPU only) 470
• Issue Type( questions, new requirements, bugs) questions
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Hi, currently I am using deepstream 6.0 dev container environment (x86). I want to develop some gstreamer plugins based on VPI library. The latest VPI version that I can get is 1.0.15 (following some steps in VPI Getting Started page). That brings some conflicts that deepstream 6.0 nvtracker requires VPI 1.1. If I link my application and plugins with VPI 1.0.15, then nvtracker will fail to initialize libnvds_nvmultiobjecttracker.so ()
dlopen error: /opt/nvidia/vpi1/lib64/libnvvpi.so.1: version `VPI_1.1’ not found (required by /opt/nvidia/deepstream/deepstream/lib/libnvds_nvmultiobjecttracker.so)
In summary, my question is how to install VPI dev package 1.1 (1.1.12) in deepstream 6.0 dev container environment (x86).
Thanks,

The vpi library is already in DeepStream SDK package. You don’t need to install by yourself.

Please follow the DeepStream SDK installation instructions. Quickstart Guide — DeepStream 6.0 Release documentation

Hi Fiona, I can find only runtime package (.so library), not headers or Cmake config file in DeepStream 6.0 image

Please check the container. The library is /opt/nvidia/deepstream/deepstream-6.0/lib/libnvvpi.so.1.1.12. And the static link /opt/nvidia/deepstream/deepstream-6.0/lib/libnvvpi.so.1 is linked to it. You need to install the same version and relink to the library you installed to avoid conflict.

Please follow the instructions shown in VPI installation documentation, but replace step 3 with the following:

For Ubuntu 16.04:
sudo add-apt-repository ‘deb https://repo.download.nvidia.com/jetson/x86_64/xenial r32.6 main’
For Ubuntu 18.04:
sudo add-apt-repository ‘deb https://repo.download.nvidia.com/jetson/x86_64/bionic r32.6 main’

Alternatively, you can download the needed packages from here:

Ubuntu 16.04:
libvpi1_1.1.12_amd64.deb
vpi1-dev_1.1.12_amd64.deb
Ubuntu 18.04:
libnvvpi1_1.1.12_amd64.deb
vpi1-dev_1.1.12_amd64.deb

Hi, I tried .deb packages from repo download page but the library depends on CUDA 10.2, not gonna work with DeepStream 6.0 docker image (CUDA 11.4). Can you confirm that? Thanks.

Yes, you’re right. We do have an internal VPI-1.1 build for CUDA-11.4. I’ll check if/how we can release it.