Web camera source in problems

Please provide complete information as applicable to your setup.

• Hardware Platform (Xavier)
**• DeepStream Version 4.0
• JetPack Version (4.2.3)
**• TensorRT Version 5.1
• NVIDIA GPU Driver Version (valid for GPU only)
Confronting with several problems while using web camera to source in deepstream, using “uri=rtsp://admin:password@IP” as the uri address and source type = 4:

  1. display problem: when the source is live camera, I cannot left click the display window into the secondary detection details mode, while the runtime command on keyboard can be done;
  2. input problem: to add the source in the config file, I cannot use the “num_source” parameter to increase the source number. I have to add manually by adding another source block named [source1];
  3. input problem 2: the max number of sources cannot be larger than 6. If more than 6 inputs are given, there would be an error and only 6 sources can be shown in the tiler window.
    All the problems happen only when using web camera, using local files as input are all good. How can I solve these?

Cloud you use latest DS 5.0 which has fixed more issues related to RTSP?

My linux version is L4T 32.2.1. It seems that only DS 4.0 can be installed. Can I install DS 5.O on L4T 32.2.1?

No, you also need to upgrade the Jetpack

Hi bcao,

I’m able to use DP5 now, but the problem is still not solved.
I’m using the deepstream-app to run deepstream and this is the error returned:

It seems like a rtspsrc problem from the rtsp lib depended in gstreamer.
And my source txt file is here:
source_live_camera.txt (3.2 KB)
I source in a rtsp camera input for 8 times, where the problem still there when I source in more than 6 inputs.

Could you create a new topic to track this issue? I don’t think it’s a DS issue per the log.

Yes, I’ve create a new topic: Web camera rtsp souce in problem