weird error about linking to 'cutil_inline.h'

I was playing around with a sample project (template) provided with CUDA SDK.

It could be compiled and run w/o any problems in its original location. But it gave the following error when I copied the project to another location. : fatal error C1083: Cannot open include file: ‘cutil_inline.h’: No such file or directory

Any idea?

cutil_inline.h is located somewhere within the common subdirectory (common/inc, maybe?), so you’re breaking that path.

thanks for your response.

I found where cutil_inline.h is

C:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\common\inc

and put the path into Configuration Properties → C/C++ → General:->Additional Include Directories

but still doesn’t work

The original path in the command line for compiling is
Now I changed to

it works now

But it’s ridiculous, I did everything exactly according to official document “Creating Your Own CUDA Program” in CUDA_SDK_release_notes_windows.txt (CUDA SDK 2.2)
No one test them before releasing???

I now encountered the same problem.

However, I am unable to edit the command line options which are greyed out. This is the case for all the SDK samples.

I’m using SDK 2.2 WinXP VS2005

Did you have the same problem? And if so, how did you get around it?

Thanks in advance.

Thanks alot for spelling this out. It helped me eliminate a few errors.

i had the same problem

u should add the “…\common\inc” direcotry into the additional include directories under CUDA BUild Rule, which u have embeded in MS Visual Studio.

The location of cutil_inline.h was, for me, in the hidden folder ProgramData and as follow :

C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.2\C\common\inc

I fixed the C1083 issue doing this :
Right click on your project (vs8) > Properties
Custom build step
Command line > adding this : -I"C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.2\C\common\inc"

Hope this can help you…