Weird OpenCL bug OpenCL/OpenGL interop bug

Hello to everyone in nVidia land. This is my first post on the forum but i’ve been an avid reader for some time now. I’ve got a little problem and would greatly appreciate some assistance.

OK…so i’m trying to write a ray-tracer using opencl/opengl interop. I’ve previously written a CPU raytracer which worked perfectly but ran VERY slowly. OpenCL GPU programming speedup seemed to be what I needed. But here’s my issue. Whenever I use CL/GL interop I get a weird bug. One side of my screen is totally black while the other side has my rendered image. My friend had the exact same problem and the way he solved it was by (i’m NOT kidding) changing the order of the arguments passed to the OpenCL kernel. I’ve tried to to the same but no ordering that I try seems to work.

My nVidia driver is: 260.19.06

I’m running a: GeForce 8600M GT

Below are screenshots of the errors i’m getting. Any help would be appreciated.

I’ve also seen bugs with the OpenCL -> PTX compiler in the past that depend on the order of kernel arguments. I’d recommend to just try a more recent driver. As you seem to be on Ubuntu, try http://www.webupd8.org/2010/06/how-to-install-nvidia-25635-display.html

Thanks eyenex for the response. I figured out the problem and will gladly share the solution with all. My problem was that writing to floating point textures doesn’t really work with CL/GL interop so when I interop and write to a floating point texture…nothing works correctly. To fix use int textures with 8-bits per color channel.