What is the best way to control the jetson Orin GUI remotely?

I am trying to remotely access a jetson Orin’s GUI and I got a dummy display port to act as a display and allow me to use Teamviewer and control the device remotely. However, when I turned on the device the GUI didn’t load up. Do I need to make any configuration changes on the jetson for the dummy display to work? What is the best way to control the jetson Orin GUI remotely?

Hi user133662,

Are you using the devkit or custom board?

Does your Orin could work normally with an external DP monitor?

You could refer to the following instruction to access your board throughVNC.
Setting Up VNC | NVIDIA Developer

I am using Devkit.

Yes, with an external DP monitor plugged in works normally.

VNC does not work if I unplugged the Display port monitor.
The VNC instrucctions in L4T-README/README-vnc.txt says that VNC allows you to work physically remote from the Linux for Tegra system, and avoids the need to connect an HDMI display, USB keyboard, or
mouse. However when I try it on my jetson Orin the connection freezes.

Why does the dummy display port adapter doesn’t work?

Sorry, we haven’t verified kind of this dummy display port adapter.

For your use case, you might could refer to the following steps to enable virtual display for VNC.

Step 0: Enable Screen sharing through connecting monitor first
Settings → Sharing → Screen Sharing → set ‘Active’

Step 1: update and install xserver-xorg-video-dummy

$ sudo apt update
$ sudo apt install xserver-xorg-video-dummy

Step 2: Create config for dummy virtual display

$ cd /etc/X11
$ sudo vim xorg.conf.dummy

Step3: Add the following contents in xorg.conf.dummy (resolution 1920*1080 as example)

Section "Device"
    Identifier "DummyDevice"
    Driver "dummy"
    VideoRam 256000
Section "Screen"
    Identifier "DummyScreen"
    Device "DummyDevice"
    Monitor "DummyMonitor"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
        Modes "1920x1080_60.0"
Section "Monitor"
    Identifier "DummyMonitor"
    HorizSync 30-70
    VertRefresh 50-75
    ModeLine "1920x1080" 148.50 1920 2448 2492 2640 1080 1084 1089 1125 +Hsync +Vsync

Step 4: Update /etc/X11/xorg.conf

$ cp xorg.conf xorg.conf.backup
$ cp xorg.conf.dummy xorg.conf

Step 5: Reboot the board

$ sudo reboot

@KevinFFF Just tried following the steps you mentioned. I only see this:

I managed to get it to working by modifying the file /etc/X11/xorg.conf
I recommend making sure ssh works and creating a backup of xorg.conf because if you want to connect a monitor again you need the old configuration.

Modifying the file /usr/share/X11/xorg.conf.d did not do any effect.

Thanks @KevinFFF

1 Like

@KevinFFF I just figured I cannot run any sample python application when using VNC with the Dummy driver. I get the following warning:

libEGL warning: DRI2: failed to authenticate

And the following error:

Error: gst-resource-error-quark: Failed to set buffer pool to active (1): /dvs/git/dirty/git-master_linux/deepstream/sdk/src/gst-plugins/gst-nvinfer/gstnvinfer.cpp(943): gst_nvinfer_start (): /GstPipeline:pipeline0/GstNvInfer:secondary2-nvinference-engine
Exiting app

It seems like to run it needs to be connected to a monitor or just from the command line using ssh.
How can I run the application using VNC? I have a GUI that shows the stream with detections and want to deploy on the edge.

Could you run this application with the monitor connected?

If it could work with command line, you may connect your device with VNC (to show the GUI) and SSH (to enter command) at the same time.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.