What will happen when NvMediaEncodeRCParams.averageBitRate set to 0 with rateControlMode set to NVMEDIA_ENCODE_PARAMS_RC_CBR??

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.8.1
[*] DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)
DRIVE OS 6.0.4 SDK
other

Target Operating System
[*] Linux
QNX
other

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
[*] DRIVE AGX Orin Developer Kit (not sure its number)
other

SDK Manager Version
[*] 1.9.3.10904
other

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
[*] native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other

I tried to pass NvMediaEncodeRCParams filled with all zero to NvMediaIEPSetConfiguration for h265 encoding, the encoding seems appears to be normal.

I want to what I have done is an undefined behavior or there is a default bitrate when user pass zero to the encoder.

I have read the document from NVIDIA DRIVE OS Linux SDK API Reference: NvMediaEncodeRCParams Struct Reference | NVIDIA Docs, yet I didn’t found any information about this question.

Dear @xu.jun36,
Did you make this changes in nvmedia sample? Can you share output log and syslog ?

I will check on this internally.

When passing NvMediaEncodeRCParams filled with all zeros to NvMediaIEPSetConfiguration for H.265 encoding, it will be treated as the Constant QP mode with default QP values. Is it aligned with your observation?

1 Like

thanks for replay

yes,the encode result with all zero NvMediaEncodeRCParams is similar to the result with const QP mode and default qp value

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.