When I input multiple sources, [tracker] and [secondary-gie0] fail

**• Hardware Platform (Jetson / GPU)**jetson NX
• DeepStream Version 5.0.1
**• JetPack Version (valid for Jetson only)**4.4
• TensorRT Version 7.1.3.1
my pipeline : detection–>tracker–>recognition.
lp_rtsp.txt (4.7 KB)
When I input multiple sources, [tracker] and [secondary-gie0] fail .
Only the [primary-gie] detection target.
How can I solve it?
thanks!

How do you know the tracker and the sgie fail?

Your config file looks fine. Just a little modification is needed. In [streammux] group, the batch-size should be 2.
https://docs.nvidia.com/metropolis/deepstream/dev-guide/text/DS_FAQ.html#what-is-the-difference-between-batch-size-of-nvstreammux-and-nvinfer-what-are-the-recommended-values-for-nvstreammux-batch-size

Thank you for your reply!

When there is only one source, I can see the detection box and target label, tracking number, and recognition result on the video. But when inputting two sources, only the check box can be seen.
I set the batch-size is 2.

The result is the same as above.
I want to see the detection box and target label, tracking number, and recognition result on the video even in the case of multiple sources. what should I do?
Thanks!

Hi,
Which sample did you use?

Thanks for your reply~
I try to build my own pipeline
lpv4_test.txt (4.4 KB)
run this command

deepstream-app -c lpv4_test.txt

Please run with -t option
-t, --tiledtext Display Bounding box labels in tiled mode

It works!
Thanks very much!