When will later kernels be supported?

I don’t have any PCI-e machines at home so I take a box home from work. I had been given permission to do Open Indina stuff at home. I want to leave everything intact so I stick in a Cuda card and a harddrive. Install Linux, driver and SDK. Oh, it won’t support the kernel in Fedora 15, ok drop back to fedora core 13. build samples, borrow Cuda book from library where wife did PhD and everything is okay. Then work demands the box back, I put everything back to how it was and return it.

Okay go buy a machine with PCI-e slots open it up and its all 1 x PCI-e and one 16 x PCI-e. Great, stick in my Cuda card and install FC-13. oh great, doesn’t recognise the inbuilt NIC. Drop the FC-15 Live CD in there and the NIC is automatically configured out of the box. Its all 1 x PCI-e so I can’t put a an old Linux supported PCI NIC in it. I can’t use the CUDA card and the NIC at the same time. There is nothing wrong with the hardware, it works with FC-15, so I can’t return it. I don’t tend to use Linux as a desktop and would likely just jam it under and old Tezro and ssh into it.

So if the CUDA kernel driver supported later kernels as well as the one in FC-13 that would be really really really useful for me.

Regan

It usually does. Install the kernel sources as well, and the CUDA driver will recompile the glue layer for the installed Linux kernel.

The part where CUDA does not work well with newer Linux distributions is that it is not compatible with gcc 4.5 or 4.6. So you should be able to either take FC 15 and install gcc 4.3 or 4.4 on it, or drop in a newer kernel on FC 13.
(I haven’t tried myself on Fedora, but I regularly do the same with openSUSE).

Thanks for your reply, I will attempt your suggestions, investigate further, but I think I might try the install gcc 4.3 or 4.4 suggestion first.

I might also look into other distributions, but I’ve been a RHEL/Fedora guy for maybe like a decade or more… yum/up2date/apt-get/whatever/… shouldn’t be too difficult to adapt.

I don’t have a lot of time to mess with it as I have a completely unrelated programming book to write and only two chapters away from an advance from the publisher ;).

Cheers,

Regan.

I don’t think there’s a reason to jump distributions here. The problem is the same on all of them.

If you intend to compile gcc from source and don’t have much time, gcc 4.3 is a lot easier to compile as gcc 4.4 has some fancy dependencies (but I guess you know that already).

I’ve Fedora 15 and I have the sources installed. Installing the dev driver fails and insists that the sources are absent.

Much mucking about inside the dev driver install code after running the installer with the -x switch to unpack everything reveals that there is an explicit test in kernel/configtest.sh for kernel subversion levels >= 6. Fedora 15 uses 2.6.40 at the moment and so the test fails.

Various crude hacking of the sources failed to produce anything which worked for me, but if any others are feeling brave and are successful, please post here so we can all have a go.

Of course, the real solution would be for Nvidia to support modern releases of Linux. That’s a hint ;-)

Paul

I think you can also go in the cuda/include/host_config.h file and comment this line out
so it looks like this:

/* #error – unsupported GNU version! gcc 4.5 and up are not supported! */

I think what Gcc 4.5+ breaks is the cuda debugging capability, if you don’t use that, then you just
comment this out and continue with Gcc 4.5 and higher.

As I read kernel/configtest.sh, the test for sublevel<=5 is only executed if <linux/version.h> is not found, i.e., the kernel headers could not be located properly.