Why all the errors on bootup

Why from a fresh install does the b01 Nano display all these errors, i can access the hardware fine once booted up but the errors are so annoying at bootup.
NVIDIA Jetson Nano Developer Kit 4GB (B01)
Jetpack 4.61
ubuntu 18.?


They are not error…
They are just some normal booting log so nothing to worry or panic about.

Thank you DaveYYY, i don’t suppose there are any boot options that can be set to supress the showing of the logs are there.?

No, there are not.

Ok that is that sorted then. Thanks for your prompt reply.

Incidentally, one of the biggest producers of such messages are when a custom carrier board (one not an exact match to the dev kit) is used without updating the device tree.

Well i bought the Nano 4gb B01 development kit new so i assume its correct.

Is there a link on how to update the device tree that i might have to do.?

If you are sure it’s a DevKit from NVIDIA instead of some custom boards from third-party vendors, and everything works fine except those messages, then I think there’s nothing to worry about.

I’ll emphasize that what @DaveYYY said is important: If you use the default NVIDIA device tree with the developer’s kit, then you’ll always have the right device tree. If you were to somehow flash for the wrong model of Jetson, then you would probably run back into the issue of some functions not working. The reason I’m reminded of an incorrect tree is that failure to find non-plug-n-play parts of the system (such as i2c or Wi-Fi if and only if Wi-Fi hardware is integrated) is quite often simply because of the inability to find that hardware (which has its placement determined by the device tree on the software side). Other errors, such as USB signal quality, are in general not related to device tree (but can be related to design of copper traces which the device tree has been told to use).

The screenshot you had earlier is really inadequate to suggest any more details. What you really need if you want to know more is a full serial console boot log (which would not require screenshots since the serial console program runs on the host PC and can log entire sessions). Sometimes when you see boot errors it is because the software is simply telling you the hardware does not exist and the driver has been testing if the hardware is there. At other times you see the end result because of some earlier issue, e.g., a power rail was not running, but you can’t tell if that is the case without the full serial console boot log (serial console runs during boot stages as well, and your screenshot and dmesg is only from when Linux runs; Linux inherits hardware state from boot content so both matter). Incidentally, a full serial console would also indicate which device tree is loaded.

You can find serial console information here:

1 Like

Not sure if you were asking me to post the below and also hope its ok to do so but ran dmesg through putty and ch340:
Incorrect dmesg log after startup removed to keep post thread clean.

dmesg is only from after the Linux kernel loads, and does not include boot stages. PuTTY should be able to create a log file, which you can start before power is applied to the Jetson. As a result, some boot stage content will be included (plus it would basically have the dmesg content after the boot stage log content). Then you can attach the log as a file to the forum thread (this makes it easier to search the log).

Putty boot log session attached.
putty.log (23.1 KB)

I should add that the hardware i have install is:
Waveshare Audio Card for Jetson Nano
Raspberry pi noir camera v2 imx219
Waveshare AC8265 Wireless NIC Applicable for Jetson Nano 2.4G / 5G WiFi Dual Mode Module
Plus dongle for wireless keyboard

Can I verify if this has a native HDMI monitor attached? Is there any kind of adapter on the HDMI? The reason I ask is because it thinks there is no HDMI attached, and then it goes on to say there is an invalid EDID. The EDID is obtained via the DDC wire in the HDMI cable, and several forms of adapters cut that wire. Also of interest, the EDID is using an i2c protocol, and you are getting i2c errors. There is more than one i2c bus, and I suspect that one of the address 0x50 bus errors is the DDC wire of the HDMI (0x50 on one bus is for EEPROM query, the other is for DDC, but I don’t know which is which). It is possible that an error on the DDC wire interferes with i2c query on the other address in some cases. All of this begs to start with figuring out if the HDMI cable itself is correct or not.

Also, note that the HDMI issues are showing up in boot stages prior to Linux ever being reached. That tends to say that the issue is not just something running in software in Linux. Device tree issues are one example of something which can relate to this even before Linux loads, so if you have any modification of carrier board, device tree, HDMI port, or kernel configuration, then that is important to know.

Yes I am using only one monitor for switching between PC and nano so I assume that is the htmi switcher box giving that assumption.

In regards to the HTMI errors and suspect HTMI switcher box i redone the serial log with direct display connection and attached the log. Think that solved the HTMI port error and hopefully everything else looks ok to you.
directdisplay.txt (24.3 KB)

That solved a lot of errors. There is still an i2c error from address 0x50, but I don’t know if this is from the EEPROM bus or the HDMI bus. Most likely not HDMI since there seems to be successful DDC/EDID. Sometimes you see such errors just because some hardware does not exist on some models. Does the Jetson now work correctly?

FYI, I think the iwlwifi Wi-Fi setup, if Wi-Fi is present, might be a different topic if the Jetson otherwise now functions correctly. You will definitely see a lot of imx219 setup errors when no imx219 camera sensor is present, it is just the way the system works by probing to see if the hardware is present. Similar for Wi-Fi, but it is possible your system has Wi-Fi hardware.

Yes it seems to work correctly and i do have installed hardware as mentioned earlier and camera present:
Installed and connected hardware:
Waveshare Audio Card for Jetson Nano (Tested audio out and in both work)
Raspberry pi noir camera v2 imx219 ( tested and works apart from the horrible pink tint)
Waveshare AC8265 Wireless NIC Applicable for Jetson Nano 2.4G / 5G WiFi Dual Mode Module (wifi and bluetooth work ok)

I have in the past had a pca9685 servo adapter connected to the nano i2c which is no longer connected at present so unless its looking for that.

I am a bit concerned about the Nano thinking the imx219 camera is missing but works during python programs, however sometimes it says camera not present in other programs. Is possible that the bootup is not getting an answer in time from the camera interface as i do have an new 18" ribbon cable fitted and i think i am right in saying I2C doesn’t like long connections. Just a thought.

I will to eliminate the possibility, reconnect a pca9685 and install the shorter original camera ribbon cable and do another boot log.

I installed my original sd card and after reconnecting above hardware including pca9685 etc i did another log and i cannot find the error from address 0x50 no longer.
putty.log (23.9 KB)