WindowGLFW problem

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

After installing Drive Software 10.0, I tried to run some sample, but it shows this error:
Screenshot from 2021-09-03 18-21-23

I am using Nvidia Driver 440.59 and cuda 10.2:

I also tried to reinstall cuda10.2 a couple of times and still have this problem. What should I do to solve this?

Dear @benson.chen,
Could you confirm if you have installed CUDA via sdkmanager and installed aa prerequisites to compile DW samples on x86(DriveWorks SDK Reference: Getting Started). Also, please check for previous forum thread topic to see if they help to provide resolution. I guess you have issue with GL and not DRIVE SW on your host. You need to fix GL issue before trying DRIVE SW on host.

Please see if “x86 Host System Prerequisites” in NVIDIA Documentation Center | NVIDIA Developer helps. Thanks.

I found out that I added –no-opengl-files when I install the Nvidia driver, if you use desktop and have the same issue, try to install Nvidia driver without –no-opengl-files , this works for me.

1 Like

Dear @benson.chen,
Thank you for sharing the solution.