Xavier NX devkit + 900-83668-0000-000 | Jetson Xavier NX Module (with 16GB eMMC)

Good day,

I’m working with Xavier NX development kit, but I replaced the original SoM to SoM with 16GB eMMC on it.
I’m tryed to install JetPack 4.5.1 and also JetPack 4.6.
In SDK manager I can choose between Xavier NX and Xavier NX devkit.

I tried to use all 4 scenarios, none of them worked.

After the failure in sdkmanager, I navigated to the newly created Linux_for_Tegra folder and also tried to burn the SoM from there with different configurations, like jetson-xavier-nx-devkit or jetson-xavier-nx-devkit-emms.
The SoM is in recovery mode, each time before the burn process.
Sometimes the burn process succeed, but the board is not able to boot.

Please advice

sdkmanager and Linux_for_Tegra are using the same flash tool.

But Linux_for_Tegra case requires you to prepare the rootfs package and run some commands manually.

As for your case, you can try to dump the uart log after you flash so that we can know why it cannot boot.

Hello Wayne,

Those are a few debug port outputs:
[0017.539] I> tegrabl_tca9539_init: i2c bus: 1, slave addr: 0x44
[0017.547] W> fetch_driver_phandle_from_dt: failed to get node with compatible ti,tca9539
[0017.555] W> fetch_driver_phandle_from_dt: failed to get node with compatible nxp,tca9539
[0017.560] W> tegrabl_tca9539_init: failed to fetch phandle from dt
[0017.568] I> fixed regulator driver initialized
[0017.578] I> CPU: Nvidia Carmel
[0017.579] I> CPU: MIDR: 0x4e0f0040, MPIDR: 0x80000000
[0017.579] I> chip revision : A02P
[0017.582] I> Boot-device: QSPI
[0017.585] I> Boot_device: QSPI_FLASH instance: 0
[0017.590] I> QSPI source rate = 204000 Khz
[0017.593] I> Requested rate for QSPI clock = 34000 Khz
[0017.598] I> BPMP-set rate for QSPI clk = 34000 Khz
[0017.603] I> QSPI Flash Size = 32 MB
[0017.611] I> Qspi initialized successfully
[0017.611] I> qspi flash-0 params source = boot args
[0018.005] E> Error in command_complete 18001 int_status
[0018.006] E> OCR failed, error = f0f0706
[0018.006] E> Failed to open sdmmc-3, err = f0f0706
[0018.006] E> Failed to initialize device 1-3
[0018.007] E> Top caller module: SDMMC, error module: SDMMC, reason: 0x06, aux_info: 0x07
[0018.007] I> TBoot-CPU Recovery hang

Hi again,

I’m also attaching a file with prints from Linux_for_Tegra folder
I’m executing the command:
sudo ./flash.sh -r jetson-xavier-nx-devkit-emmc mmcblk0p1

the output in attached fileterminal_output.txt (53.3 KB)

Hi,

Is the uart log you shared a log when you are doing flash?

Is there any log for doing the “boot”?

Hi,

What I shared is a fail in the burn process. Since it failed to burn, I didn’t think there is a point to share a boot log.
My fault.

I’m attaching the boot log now.
terminal_output.txt (54.5 KB)

Let me clarify something here

According to your previous comment, it sounds like there are 2 issues here.

You firstly said “Sometimes the burn process succeed, but the board is not able to boot.”. Which means the board is able to get flashed but not able to boot.

For the flash issue, please make sure it is not due to micro usb cable or host side, try different host and cables if possible. Also, use other NX device to validate your hardware is also an option.

For the boot issue, the log tells that some partitions on your NX are lost. Which means the flash process is incomplete.

Is the log you just shared from a “successful flashed” case?

Nope,

The flash process is failed and the log is of the next boot.
Ignore y previously mentioned state that sometimes is succeded.

I can’t burn and I can’t boot the development kit + SoM with 16GB eMMC on it.
Please advise, how I can make it work (without the use of SDCARD).
I got the latest sdkmanager, I got HW. I’m using a PC with Ubuntu 18.04 on it.
How to make it works from a scratch?
Thanks in advance

Hi,

It is possible a hardware defect here. That is why I asked you to try more module and carrier board to validate.

Sorry,

This is not possible at the moment. I got 1 module and 1 devkit.

Hi,

NX does not have different carrier boards. Which means sdcard module and emmc module should both work on p3509 carrier board.

Under current situation, I would suggest you can RMA this device and get a new one to try.

Thank you.

I’ll do it. Hope that this will solve the issue.