Xavier NX no graphical display after installing jetpack

I have the Xavier NX dev. kit (with sdcard 32GB). I’ve flashed it using the nvidia’s instructions “Preparing a Jetson Developer Kit for Use” using ./flash.sh script.

After first installation I’ve installed the jetpack on the device by running sudo apt install nvidia-jetpack, following the section 1.3.1 in How to Install JetPack :: NVIDIA JetPack Documentation
The installation is done from the gnome.

After reboot I cann’t see the GUI interface, only the serial terminal. (CTRL - ALT F1-F7 didn’t help)

If I disconnect the display I’m getting the following messages:
[ 128.161344] tegradc 15200000.nvdisplay: FB 265420800 is NOT enough for 42949!
[ 129.691598] tegradc 15200000.nvdisplay: FB 265420800 is NOT enough for 42949!
[ 130.150525] tegradc 15200000.nvdisplay: FB 265420800 is NOT enough for 42949!

Content of the file /etc/X11/xorg.conf:
Section “Module”
Disable “dri”
SubSection “extmod”
Option “omit xfree86-dga”

Section “Device”
Identifier “Tegra0”
Driver “nvidia”
Option “AllowEmptyInitialConfiguration” “true”

lsmod output:
Module Size Used by
xt_conntrack 3979 1
ipt_MASQUERADE 2634 1
nf_nat_masquerade_ipv4 3993 1 ipt_MASQUERADE
nf_conntrack_netlink 33224 0
nfnetlink 9716 2 nf_conntrack_netlink
xt_addrtype 3915 2
iptable_filter 3008 1
iptable_nat 3423 1
nf_conntrack_ipv4 14222 2
nf_defrag_ipv4 2129 1 nf_conntrack_ipv4
nf_nat_ipv4 8176 1 iptable_nat
nf_nat 25276 2 nf_nat_masquerade_ipv4,nf_nat_ipv4
nf_conntrack 132217 6 nf_conntrack_ipv4,nf_conntrack_netlink,nf_nat_mt
br_netfilter 17588 0
zram 29561 6
nvgpu 1734537 0 [boot_log|attachment]
bnep 19078 2
rtk_btusb 68473 0
overlay 53481 0
hid_logitech_hidpp 25618 0
btusb 44699 0
hid_logitech_dj 15774 0
btrtl 7813 1 btusb
btbcm 10207 1 btusb
btintel 13507 1 btusb
rtl8822ce 3465318 0
cfg80211 710371 1 rtl8822ce
userspace_alert 6769 0
ip_tables 21475 2 iptable_filter,iptable_nat
x_tables 38080 5 ip_tables,iptable_filter,ipt_MASQUERADE,xt_addrk

What could be the reason for that issue?
How can I fix it?

Please help


dmesg_log (150.7 KB)
boot_log (62.6 KB)

  1. Please check “df -h” and see if the disk space is full. Full disk will also cause desktop fails to launch.

  2. Please also check /var/log/Xorg.0.log

And which jetpack version are you using now?

Hi WayneWWW,
Thanks for your response,

It seems like there is enough space on the sdcard,
df -h output
Filesystem Size Used Avail Use% Mounted on
/dev/mmcblk0p1 31G 17G 14G 56% /
none 3.7G 0 3.7G 0% /dev
tmpfs 4.1G 0 4.1G 0% /dev/shm
tmpfs 4.1G 55M 4.1G 2% /run
tmpfs 5.3M 4.1k 5.3M 1% /run/lock
tmpfs 4.1G 0 4.1G 0% /sys/fs/cgroup
tmpfs 815M 0 815M 0% /run/user/1000
tmpfs 815M 4.1k 815M 1% /run/user/120

Xorg.0.log file is attached
Xorg.0.log (28.0 KB)

I’ve downloaded the Jetson_Linux_R32.6.1_aarch64
and using rootfs from archive Tegra_Linux_Sample-Root-Filesystem_R32.6.1_aarch64

sudo apt show nvidia-jetpack output
Package: nvidia-jetpack
Version: 4.6-b199
Priority: standard
Section: metapackages
Maintainer: NVIDIA Corporation
Installed-Size: 199 kB
Depends: nvidia-cuda (= 4.6-b199), nvidia-opencv (= 4.6-b199), nvidia-cudnn8 (= 4.6-b199), nvidia-tensorrt (= 4.6-b199), nvidia-visionworks (= 4.6-b199), nvidia-container (= 4.6-b199), nvidia-vpi (= 4.6-b199), nvidia-l4t-jetson-multimedia-api (>> 32.6-0), nvidia-l4t-jetson-multimedia-api (<< 32.7-0)
Homepage: Autonomous Machines | NVIDIA Developer
Download-Size: 29.4 kB
APT-Manual-Installed: yes
APT-Sources: https://repo.download.nvidia.com/jetson/t194 r32.6/main arm64 Packages
Description: NVIDIA Jetpack Meta Package


  1. Your kernel log is being truncated. Please make sure you get the full log … For example, below is what I saw from your log.

[ 0.000000] Kernel command line: console=ttyTCU0,115200 video=tegrafb earlyc0

  1. Your xorg does not run NVIDIA X driver. It somehow goes to use fbdev driver. And it failed.

That tegra0 line does not appear in your xorg log.

[     9.653] (==) No device specified for screen "Default Screen Section".
        Using the first device section listed.
[     9.653] (**) |   |-->Device "Tegra0"
[     9.653] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.

and these lines too.

[     9.713] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[     9.747] (II) Module nvidia: vendor="NVIDIA Corporation"
[     9.747]    compiled for 4.0.2, module version = 1.0.0
[     9.747]    Module class: X.Org Video Driver
[     9.766] (II) NVIDIA dlloader X Driver  32.6.1  Release Build  (integ_stage_rel)  (buildbrain@mobile-u64-5497-d3000)  Mon Jul 26 12:17:10 PDT 2021
[     9.766] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs

Are you sure you just hit this issue with sample rootfs + apt-get install nvidia-jetpack?

Could you check both of your host side (Linux_for_Tegra/rootfs) and device side to see if this file exists?


I wanted to be sure that I installed everything correctly, so I did the whole process and installation from the begining, and it worked.
I thought that I did the same process but probably at the first time I missed something.
I don’t know what was the problem before but now it works fine.

Thanks for your help

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.