[ Xavier NX ] SDMMC3 status disable

Dear Sir,

I’ve refer some post on this FORUMS about enable the SDMMC3.
But it always disable under the OS as the log below show.

root@lanner-desktop:~# cat /proc/device-tree/sdhci@3440000/status 

root@lanner-desktop:~# cat /sys/firmware/devicetree/base/__symbols__/sdhci_sd

xavier_sdmmc3_20211108_1918.log (183.9 KB)

Would you mind to help me to figured out which part I missed or setting wrong. There is the final device tree which reverse from the kernel/dtb/tegra194-p3668-all.dtb
tegra194-p3668-all-p3509-0000_20211108_1943.dts (268.6 KB)

I’ve tune the sdhci_sd to the sdmmc3(sdhci@3440000) and disable the sdmmc1(sdhci@3400000).
PATH : hardware/nvidia/platform/t19x/jakku/kernel-dts/common/tegra194-p3668-common.dtsi
tegra194-p3668-common.dtsi (11.9 KB)

I’ve also been tune the gpio since the GPIO7(PortR.00) of SOM will be a Power Control to our SD Card Slot in Carrier Board. PATH : hardware/nvidia/platform/t19x/jakku/kernel-dts/common/tegra194-fixed-regulator-p3668.dtsi
tegra194-fixed-regulator-p3668.dtsi (1.6 KB)

And Tune the GPIO13(PortN.01) to the SDMMC3_WP with pinmux table.
PATH : hardware/nvidia/platform/t19x/jakku/kernel-dts/
tegra194-p3668-all-p3509-0000.dts (29.6 KB)

Best Regards,

If your final dtb has enabled the sdmmc3 but the /proc/device-tree says it didn’t.

Maybe you should share how you updated the device tree on the board. I guess that step might be wrong.

Dear Wayne,

Thanks for your reply.
I’m still use this command to update/flash the whole eMMC so far.

#sudo ./flash.sh jetson-xavier-nx-devkit-emmc mmcblk0p1

Is there any command we could to instead of it?

Best Regards,

Where did you put the new dtb file?

Dear Wayne,

As I revert the final dtb file from the kernel/dtb/tegra194-p3668-all.dtb
The whole dtb path which I put that should be


And the dtb I built path that should be


Best Regards,

The default dtb name should be “tegra194-p3668-all-p3509-0000.dtb”. Are you sure your naming is correct?

Dear Wayne,

Actually, I’ve copied the final dtb and rename with a time-stamp for compare their different.

Best Regards,

please also remove the plugin-manager in this dts.

The fragement-tegra-sdhci-sd-dis disabled your sdhci.


Dear Wayne,

Thanks!! the sdhci@3440000’s status is “okay” now.

$ cat /proc/device-tree/sdhci@3440000/status

As your advice, it just need to mark the section as below

                fragement-tegra-sdhci-sd-dis {
                        ids = ">=3668-0001-000";
                        override@0 {
                                target = <&sdhci_sd>;
                                _overlay_ {
                                        status = "disabled";

We will keep going until this function work.
Appreciate for your help and advice kindly.

Best Regards,

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.