XID errors playing with Ryzen 5

Hi everyone.

I have many XID errors ( XID 69,32 13) specialy on 3D games (e.g. Deus Ex,XCOM2 PAYDAY2 …). The games crashes or have grafical glitches. With my old Athlon dont have any problems with my GTX 760.
Nothing is overclocked specialy the DDR4 (DDR4 2133)

Mai 14 00:00:48 u064eh systemd[1]: Started Update man-db cache.
Mai 14 00:00:57 u064eh kernel: NVRM: Xid (PCI:0000:0c:00): 69, Class Error: ChId 0032, Class 0000a097, Offset 00001b00, Data 40000001, ErrorCode 0000000c
Mai 14 00:01:01 u064eh kernel: NVRM: Xid (PCI:0000:0c:00): 69, Class Error: ChId 0032, Class 0000a097, Offset 00001b00, Data 40000001, ErrorCode 0000000c
Mai 14 00:01:32 u064eh kernel: NVRM: Xid (PCI:0000:0c:00): 69, Class Error: ChId 0032, Class 0000a097, Offset 00001b00, Data 40000001, ErrorCode 0000000c
Mai 14 00:01:53 u064eh kernel: NVRM: Xid (PCI:0000:0c:00): 13, Graphics Exception: EXTRA_MACRO_DATA
Mai 14 00:01:53 u064eh kernel: NVRM: Xid (PCI:0000:0c:00): 13, Graphics Exception: ESR 0x404490=0x80000002
Mai 14 00:01:53 u064eh kernel: NVRM: Xid (PCI:0000:0c:00): 13, Graphics Exception: ChID 0032, Class 0000a097, Offset 00002388, Data 01b45f00
Mai 14 00:01:56 u064eh kernel: NVRM: Xid (PCI:0000:0c:00): 69, Class Error: ChId 0032, Class 0000a097, Offset 00002380, Data 08004100, ErrorCode 0000000c
Mai 14 00:02:20 u064eh kernel: NVRM: Xid (PCI:0000:0c:00): 32, Channel ID 00000032 intr 00040000
Mai 14 00:02:29 u064eh kernel: NVRM: Xid (PCI:0000:0c:00): 32, Channel ID 00000032 intr 00040000

In your documatation stand XID 69 can be a hardware issue. So i test a the card in the second pci slot with the same result and i test another DDR4 bars without changes.
I test a vanilla kernel (4.11) and some older nvidia drivers without any changes. I disabled nvidia-drm ( yes in the nvidia-bug-report is it enabled) without changes.
__GL_THREADED_OPTIMIZATIONS is in all cases disabled.

So i dont have any othe idee to test. Please help me :)

Greetings from germany and a nice weekend.

[Edit 15.05]

I found this in the geforce.com forum. Sounds like the same issue.

https://forums.geforce.com/default/topic/998890/games-freezing-on-ubuntu-16-10/?offset=2
nvidia-bug-report.log.gz (244 KB)

Could you test your GPU in another PC?

Yes. I test it on my old hardware without any error. In the course of the week borrow me a Gtx 970 for a short test.

I can test it in an other Pc with the same old hardware but i dont have linux on this maschine. My wife will kill me when i install linux ^^.

Mfg

This looks like a hardware incompatibility which I’ve never encountered in my entire life.

I’d recommend that you install the latest BIOS for your motherboard and update your GPU BIOS if one is available.

Thank you for your help.

All Bios up to date. :-( I hope Asrock will release soon a new one.
For my Msi dont find a newer Bios as installed it.

Mfg

Thanks for your time.

Sorry to bump an old issue. But I want to report this is still an issue. Kernel v4.20 and Nvidia driver 415.25 - also kernel v4.18 and Nvidia driver 410 on both a 970 and 1070. Ryzen 5 2600 and x370 Mobo.

Telling by the collection of XIDs, I’d say the OP was hit by the Ryzen bug. Since you have a 2nd gen Ryzen, this shouldn’t happen in your case.
Please open a new thread, run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/