xorg.conf for NVIDIA Driver + X Windows on a server with 2 TeslaK20 GPUs + 1 MatroxG200 Graphics Card


I just setup a server (Dell PowerEdge T620) that has two Tesla K20c GPUs with CentOS 7, CUDA 7.5 and the latest NVIDIA drivers.
Everything (nvcc, cuda samples …) seems to work properly, however, I cannot start an X Server:
When I run startx it complains about no screens being connected.
The system seems to try using the K20 GPUs for connecting to a display (which does, of course, not work since these are not connected to a display).

What do I need to put into my xorg.conf to use the standard graphics card of this server (Matrox/VGA) for graphics and the GPUs only for computation?

I tried configuring 3 Devices and 1 Screen:

Section “Device”
Identifier “Videocard0”
Driver “mga”
BusID “PCI:0a:00.0”

Section “Device”
Identifier “GPU1”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “Tesla K20c”
BusID “PCI:66:0:0”

Section “Device”
Identifier “GPU2”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “Tesla K20c”
BusID “PCI:67:0:0”

Section “Screen”
Identifier “Default Screen”
Device “Videocard0”
Monitor “Monitor0”
DefaultDepth 24
Option “ConnectedMonitor” “DFP”
SubSection “Display”
Depth 24

Unfortunately, it does not work (same error as with the automatically generated xorg.conf).
I also tried Driver=“nvidia” to configure (Videocard0 like the GPUs) which did not help.

Any more ideas?

here is the error log:

X.Org X Server 1.17.2
Release Date: 2015-06-16
X Protocol Version 11, Revision 0
Build Operating System: 2.6.32-220.17.1.el6.x86_64
Current Operating System: Linux computer.ORG 3.10.0-327.36.1.el7.x86_64 #1 SMP Sun Sep 18 13:04:29 UTC 2016 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.10.0-327.36.1.el7.x86_64 root=/dev/mapper/centos-root ro crashkernel=auto rd.lvm.lv=centos/root rd.lvm.lv=centos/swap rhgb quiet nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off
Build Date: 20 November 2015 02:44:25PM
Build ID: xorg-x11-server 1.17.2-10.el7
Current version of pixman: 0.32.6
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Thu Sep 22 14:13:29 2016
(==) Using config file: “/etc/X11/xorg.conf”
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
Fatal server error:
(EE) no screens found(EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
(EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error