Xorg uses ~100% cpu when scrolling in firefox with proprietary nvidia drivers

Hi, I have an issue with firefox 20. Xorg hogs cpu when scrolling. System is responsive but the scrolling in browser is a pain. I tried google chrome and opera and the first one performed much better (~20-30% cpu, smoothly), opera was great - scrolling ok, xorg was using few percent of cpu. I also tried nouveau driver and even firefox worked like opera. I’m using kde but tried fluxbox and there was no difference. So I have no idea whether it’s firefox or nvidia or xorg fault. Any ideas?

PS. I tried starting firefox with new profile - it didn’t help. Kde konqueror works smoothly.

PC:
Slackware current 32bit
Athlon 64 3400
Geforce 7600 GS
2 GB ram
nvidia 304.88 driver
kde 4.10.2, kernel 3.8.7
nvidia-bug-report.log.gz (55.2 KB)

Hi, you should select Adwaita for GTK2-Design (GTK-configuration). This solved my problems. It seems, that oxygen-gtk or qtcurve conflict with something in firefox, when using nvidia drivers. With intel drivers on intel hardware everything is ok.

OpenSuse 12.2
Athlon X2 4400
GeForce 7600 GS
3 GB ram
same nvidia driver
same KDE, same Kernel

DiJa

Looks like https://devtalk.nvidia.com/default/topic/523281/linux/cairo-performance-regression-/

…definitely.
If you are on arch, install cairo-nvidia from aur.

Thanks DiJa, it helped.

You’re welcome.
DiJa