Xubuntu 20.04 cannot switch back to nvidia graphics


I got a Tonfang chasis laptop and I installed tuxedo-control-center for having some control over fans and also the power management. Also, I have picked the built-in graphics but right now I cannot go back to the hybrid or nvidia graphics.

When I run nvidia-smi I got;

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver > is installed and running.

For the nvidia-settings command;

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:5547): GLib-GObject-CRITICAL **: 00:58:22.942: g_object_unref: assertion ‘G_IS_OBJECT (object)’ >failed
** Message: 00:58:22.948: PRIME: No offloading required. Abort
** Message: 00:58:22.948: PRIME: is it supported? no

Also I found a cd /lib/modprobe.d/blacklist-nvidia.conf. If I delete this will I be able to switch between my builtin amd gpu and nvidia?

nvidia-bug-report.log.gz (77.0 KB)

This should give you the steps to make the amd/nvidia combo work:

What’s the content of the file? If it contains only the blacklist for nvidiafb then it should stay.
If it blacklists the nvidia driver, yeah deletion it is.

I followed this and applied, but still could not get my problem fixed. Also I have deleted the/lib/modprobe.d/blacklist-nvidia.conf. I cannot still go back to nvidia high performance settings

Please create a new bug-report.

Ubuntu 20.04 has support for amd/nvidia combos so please revert the config file changes. The instructions on the other thread are for 18.04 and before amd support was introduced in 20.04.
Can’t you just switch back to nvidia using
sudo prime-select nvidia
Furthermore, please try to manually load the nvidia module
sudo modprobe nvidia
and post any errors if there are some.

Thanks! Running sudo prime-select nvidia worked after reverting changes.