Nvidia Rtx 3060 is not getting used, AMD default card is accessed

nvidia-bug-report.log.gz (132.0 KB)

neo@neo-Nitro-AN515-45:~$ nvidia-settings

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:4918): GLib-GObject-CRITICAL **: 00:33:05.335: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 00:33:05.338: PRIME: No offloading required. Abort
** Message: 00:33:05.338: PRIME: is it supported? no

I have tried to install/re-install the driver many times, can’t figure our the issue.
Have tried to follow the steps from

Still can’t fix it. Need your Help generix
Help me out.

You have upgraded to a non-standard kernel 5.13, did you install the header files for this? Furthermore, I suspect this was built for ubuntu 21.10 and won’t work on 20.04 due to an introduce dependency on glibc, blocking module compilation. Do you need tthe upgraded kernel or can you retturn to the standard 5.11 kernel?

Thanks for the reply generix. I really appreciate it.
I recently bought this laptop Acer Nitro 5, wifi wasn’t working when i installed ubuntu 20.04. So, i updated the kernel to 5.15 and then downgraded to 5.13

You mentioned 5.13 was build for 21.10, so i upgraded ubuntu to 21.10
Deleted the nvidia drivers
Install the drivers again.
created the optimus.desktop files as you suggested.
Still cant get the nvidia driver to work.

I don’t know the difference between standard and non-standard kernel.
Here is the latest bug report nvidia-bug-report.log.gz (132.7 KB)

I upgraded to Ubuntu 2.10 and upgraded the kernel to 5.15.3 and installed the drivers. It’s working now.