[Ubuntu] RTX 3080 Does not output Video

Beginner Linux user here. I’ve got a server box loaded with an Intel S2600ST, an Intel Xeon Silver 4216, and an RTX 3080, and either Ubuntu 20.04.03 or 21.04. When I’ve had the LTS loaded, it would recognize my nVidia as a generic device, however 21.04 directly identifies it as a 3080.

I currently have this system connected with a VGA from the baseboard, which outputs fine. During the OS Boot, my main monitor (Or at least, what I’d like to use) over DisplayPort will activate with the Ubuntu loading animation, and then once that’s completed, turn right back off.

I’ve been working on this for probably 10 hours, not understanding exactly what I’m missing.

I’ve installed the latest nVidia driver 470 a variety of ways, from the general Update menu for Tested and Propietary, to CLI, to the actual .run file from nVidia.

I’ve confirmed that the driver is installed right or at least contacting the hardware with

nvidia-smi

And I’ll get what seems like a correct readout If I run

prime-select query

I’ll get an output of “nvidia”, and not intel. However, whenever I run

sudo nvidia-settings

I get the following output

(nvidia-settings:2458): GLib-GObject-CRITICAL **: 11:57:02.390: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed

** (nvidia-settings:2458): CRITICAL **: 11:57:02.392: ctk_powermode_new: assertion ‘(ctrl_target != NULL) && (ctrl_target->h != NULL)’ failed

ERROR: nvidia-settings could not find the registry key file or the X server is
not accessible. This file should have been installed along with this
driver at
/usr/share/nvidia/nvidia-application-profiles-key-documentation. The
application profiles will continue to work, but values cannot be
prepopulated or validated, and will not be listed in the help text.
Please see the README for possible values and descriptions.

** Message: 11:57:02.434: PRIME: No offloading required. Abort
** Message: 11:57:02.434: PRIME: is it supported? no

nVidia X Server Settings app will actually launch, but looks very similar to this https://i.stack.imgur.com/PB1EG.png

I think that means I’m mostly in the right-ish ballpark, however it looks to be an error with nVidia Settings not having the right configuration even when automatically or manually installed.

I currently have it set for the 470 version under Additional Drivers for Software & Updates.

I’ve seen other users with issues having a close-ish issue to mine with Secure Boot enabled, however for my issue, I have Secure Boot disabled, confirmed in the BIOS and CLI.

If you can help point me in the right direction for this one, that’d be very much rather appreciated.

Solution was to reset my BIOS for this particular issue since for some reason my onboard was overriding my add-in card.