Geforce RTX 3080 and Ubuntu 18.04, graphic display not working after reboot

Good morning:

I have been trying to install a RTX 3080 GPU on an Ubuntu 18.04 laptop since January. I have tried nearly everything but I hadn’t achieved it yet.

Could someone help me?

I downloaded the drivers from Official Advanced Driver Search | NVIDIA (GeForce, 30 Series Notebook, RTX 3080 laptop, Linux 64 bit, English UK, all).

Which version do you recommend me? I have achieved the best results with 470.82.00 version.
Executed with sudo bash ./ [an alternate method…(continue installation), 32 bit library (no → ok), nvidia-xconfig (yes → ok)].

After instalation, I am able to run nvidia-smi and get output, but if I restart my computer, I enter in the famous black screen and the only way to recover the system is to uninstall the drivers and reboot the system.
output.txt (1.5 KB)
output2.txt (6.6 KB)

I also attach the installation-report.log file…
nvidia-installer.log (34.0 KB)


→ Would you like to run the nvidia-xconfig utility to automatically update your X configuration file so that the NVIDIA X driver will be used when you restart X? Any pre-existing X configuration file will be backed up. (Answer: Yes)

Don’t use nvidia-xconfig on Optimus laptops. It will not generate a valid config.
Delete that /etc/X11/xorg.conf file.

Generally speaking it is not recommended to use the .run file installer.
Use the ubuntu distro packages, or the graphic-drivers ppa.

And install using sudo apt install nvidia-driver-XXX.

And then choose your prime profile: sudo prime-select {intel | nvidia | on-demand}.

Forgot to mention: Do not mix .run file installs with distro packages. So if you go with the second, make sure to uninstall the .run file installation with the --uninstall switch first.

Good afternoon:

I have tried the suggested method.

ignacio@ignacio-ROG-Zephyrus-S17-GX703HS-GX703HS:~$ sudo ubuntu-drivers devices
[sudo] password for ignacio:
WARNING:root:_pkg_get_support nvidia-driver-510: package has invalid Support PBheader, cannot determine support level
WARNING:root:_pkg_get_support nvidia-driver-510-server: package has invalid Support PBheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd0000249Csv00001043sd00001712bc03sc00i00
vendor : NVIDIA Corporation
driver : nvidia-driver-470 - distro non-free recommended
driver : nvidia-driver-470-server - distro non-free
driver : nvidia-driver-510 - third-party non-free
driver : nvidia-driver-510-server - distro non-free
driver : xserver-xorg-video-nouveau - distro free builtin

After that, I added the repositor and updated:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

And then I installed the suggested driver:

sudo apt install nvidia-driver-470

If i reboot, I go back to the black screen. On demand and nvidia with prime select does not work.The only way to go back is doing:

sudo prime-select intel

I attach nvidia-bug-report.log.gz too.
nvidia-bug-report.log.gz (156.4 KB)

Thanks a lot!

Mart, check previous message please!

Your kernel version 5.4 is way too old for your cpu / internal gpu:

[ 4.028076] [drm] Your graphics device 9a60 is not properly supported by the driver in this
kernel version. To force driver probe anyway, use i915.force_probe=9a60
module parameter or CONFIG_DRM_I915_FORCE_PROBE=9a60 configuration option,
or (recommended) check for kernel updates.

Thus, display offload won’t work.

Use the liquorix ppa:

Or update to a newer Ubuntu version.

1 Like

Good evening!

Updating the kernel was the solution. Complete instructions for future questions:

sudo ubuntu-drivers devices -----> gives recommended version
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt install nvidia-driver-470

uname -r
sudo add-apt-repository ppa:damentz/liquorix
sudo apt-get update
sudo apt-get install linux-image-liquorix-amd64 linux-headers-liquorix-amd64

sudo reboot
uname -r
sudo prime-select nvidia

Then NVIDIA X Server worked perfectly and nvidia-smi gave the desired output. Even screen 2 connected to HDMI port started working!

Thanks a lot!!!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.