NVIDIA Driver 510 not working for RTX 30


I recently installed the recommended proprietary NVIDIA graphics driver (510) for my PC. The installation went through but I cannot switch the graphics card from INTEL to NVIDIA.

Whenever I try running nvidia-smi, i get the following message: “No devices were found”
Whenever I try running nvidia-settings, i get the following message:

I disabled secure boot and blacklisted the nonveau driver. I have been trying to solve this problem for past 3 days and nothing seems to be working. Any help will be highly appreciated.

I have attached a bug report with this query.
nvidia-bug-report.log.gz (172.5 KB)

According to the log, secure boot is still enabled
sudo dmesg |grep secure

I ran the command listed in above comment and it says secure boot is disabled. However, I could not find the secure boot option in BIOS. I checked everything in BIOS but could not find the enable/disable secure boot option. However I have enabled dual boot type in BIOS.

Any suggestions will be highly appreciated.

Thank you so much!

When you created the log, secure boot was enabled. please create a new nvidia-bug-report.log with it disabled.

Hi Generix,
As requested I have attached the bug report here.
nvidia-bug-report.log.gz (239.7 KB)

For more information, I have attached output of some common commands.
neousys@neousys-Nuvo-8108GC-Series:~$ nvidia-smi
No devices were found

neousys@neousys-Nuvo-8108GC-Series:~$ nvidia-settings

ERROR: Unable to load info from any available system

(nvidia-settings:15834): GLib-GObject-CRITICAL **: 16:48:28.442: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 16:48:28.444: PRIME: Requires offloading
** Message: 16:48:28.444: PRIME: is it supported? yes
** Message: 16:48:28.463: PRIME: Usage: /usr/bin/prime-select nvidia|intel|on-demand|query
** Message: 16:48:28.463: PRIME: on-demand mode: “1”
** Message: 16:48:28.463: PRIME: is “on-demand” mode supported? yes

neousys@neousys-Nuvo-8108GC-Series:~$ nvidia-xconfig

Using X configuration file: “/etc/X11/xorg.conf”.

WARNING: Unable to parse X.Org version string.

WARNING: Unable to use the nvidia-cfg library to query NVIDIA hardware.

ERROR: Unable to find any GPUs in the system.

ERROR: Unable to write to directory ‘/etc/X11’.

neousys@neousys-Nuvo-8108GC-Series:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Desktop 9 Series) (rev 02)
06:00.0 VGA compatible controller: NVIDIA Corporation Device 2504 (rev a1)

neousys@neousys-Nuvo-8108GC-Series:~$ dkms status
nvidia, 510.47.03, 5.13.0-28-generic, x86_64: installed

neousys@neousys-Nuvo-8108GC-Series:~$ mokutil --sb-state
SecureBoot disabled
Platform is in Setup Mode

Prime select query gives nvidia as output.

I have been trying this for over 4 days now and nothing seems to be working.
I really appreciate your help.

The driver is loading now but the gpu fails:

[ 9.372913] NVRM: GPU 0000:06:00.0: RmInitAdapter failed! (0x26:0x56:1463)

Please check if the card is working in another system, otherwise it might be broken.

It looks like you’re using some industrial case Nuvo-8108GC with NVS-8108 mainboard. I can’t find the thread but iirc that had problems with rtx3 gpus earlier.

Hello, have you managed to solve the issue?

use 460.84 driver

I had to use driver version 470.63.01 for the RTX 3060 GPU. I downloaded the .run file and installed the specific driver.

sudo apt update
sudo apt install build-essential
sudo apt install libglvnd-dev
sudo apt install pkg-config
sudo bash -c “echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf”
sudo bash -c “echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf”
sudo update-initramfs -u

sudo ./THE FILE YOU DOWNLOADED --no-x-check


This worked for me. I dont know what the problem is but installing the proprieterty drivers from software and update never worked for me.
Hope this helps.