0 global memory CUDA 4.0 / win7@32 on mac book pro 13 after upgrading to cuda 4.0 and corresponding

I am using a Mac Book Pro 13" 2009 with a GeForce 9400M on MacOs X Snow Leopard and Win7-32 (areo disabled).

In OSX I get the proper amount of global memory (254 MB) but not on windows, therefore I think the hardware should be ok.

Note, that it worked on CUDA 3.2.

Where the following is output by deviceQueryDrv.exe:

Device 0: “GeForce 9400M”
CUDA Driver Version: 4.0
CUDA Capability Major/Minor version number: 1.1
Total amount of global memory: 0 MBytes (0 bytes)
( 2) Multiprocessors x ( 8) CUDA Cores/MP: 16 CUDA Cores
GPU Clock rate: 1.10 GHz
Memory Clock rate: 1066.00 Mhz
Memory Bus Width: 64-bit
Max Texture Dimension Sizes 1D=(8192) 2D=(65536,32768) 3D=(
Max Layered Texture Size (dim) x layers 1D=(8192) x 512, 2D=(8192,8192)
x 512
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 16384 bytes
Total number of registers available per block: 8192
Warp size: 32
Maximum number of threads per block: 512
Maximum sizes of each dimension of a block: 512 x 512 x 64
Maximum sizes of each dimension of a grid: 65535 x 65535 x 1
Texture alignment: 256 bytes
Maximum memory pitch: 2147483647 bytes
Concurrent copy and execution: No with 0 copy engine(s)
Run time limit on kernels: Yes
Integrated GPU sharing Host Memory: Yes
Support host page-locked memory mapping: Yes
Concurrent kernel execution: No
Alignment requirement for Surfaces: Yes
Device has ECC support enabled: No
Device is using TCC driver mode: No
Device supports Unified Addressing (UVA): No
Device PCI Bus ID / PCI location ID: 2 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simu
ltaneously) >
[deviceQueryDrv.exe] test results…

Press ENTER to exit…

I then switched to beta drivers where the same problem occurs.

Any ideas?

kind regards,


Hello Martin,

I am trying to set up CUDA 4.0 on my MBP 13" with win7-64 bits on a boot camp partition and I am encountering the exact same problem as you: no global memory when testing devicequery. Did you find a solution?



Do any of the SDK samples actually fail or are you just worried about the number 0?

Note that there actually isn’t any global memory on a 9400M and all memory requests are satisfied from host memory. Pre 4.0 this had to be hidden from the CUDA application, but with the unified address space I see no reason for Nvidia to still pretend there were any global memory.

Hello Tera,

Thanks for the clarifications regarding the memory requests for the 9400M.
Actually, I am having troubles trying to run the SDK samples and I was thinking that this number 0 was a potential cause. Apparently it’s not and I have to look somewhere else.

When I try to run sample applications like bandwithTest.exe or Particles.exe, I get the recurrent error on a call to cudaSafeCall() that says:
‘Runtime API error 2: out of memory.’

That’s why I was thinking that the zero was abnormal, and I cannot figure out what is going wrong…
Any leads/thoughts?



Note that I don’t have any experience with Windows, so the 0 may indeed be abnormal.


I am having exactly the same problem. In CUDA 3.2, it is probably ok but after I migrated to CUDA 4.0, almost nothing work in gpu_computing. Most of them complained out-of-memory. I’m pretty sure it worked when I was in CUDA 3.2.

It’s Macbook 13" with bootcamp windows 7 32bit.

hi huangch, thanks for your post I just switched to 3.2 and it works fine.