1>LINK : fatal error LNK1181: cannot open input file '.\Debug\deviceQuery.obj 1>LINK : fat


this is buj… i installed cuda sdk 1.1 and toolkit 1.1 version for windows xp - 32 bit… when i am doing program , gettin compile time error ike beow mentioned

LINK : fatal error LNK1181: cannot open input file '.\Debug\deviceQuery.obj … can any one hep

the error means the obj file didn’t be compiled。
check the deviceQuery.cu file and the compiler setting for it.

i have changed linker setting also , but getting same problem… below attached file is my build.html.

can you solve my problem
build.htm (6.77 KB)

right key on the cu file, and compile it first~~

Hi, I just came to this thread while searching the forums.

I’ve been working on a CUDA project for a while now. Doing this in MSVS with no problems, building, editing, building again, running, editing, building, etc. For months…no problems.

Today, all of a sudden, I get this same error mentioned above…fatal error lnk1181 cannot open input file.

Now I can’t build the file at all. What happened and how do I fix this?

I can do as you suggested and compile the actual CU file. But how does that help me. Cause when I run the program, it still wants to build the solution, and it ends up with the same error?

Please advise.