1080i output for TX1 or TX2

I can´t find any information if i can set the HDMI out of our TX1 or TX2 to a native 1080i?

I tried to set it with xrand, but i only get 1080p60 resolution out.

Is it possible to set 1080i mode anywhere?

If you find the ‘Section “Device”’ of “/etc/X11/xorg.conf”, and add this option, then booting up and viewing “/var/log/Xorg.0.log” will give information on support of modes reported by the monitor:

Option      "ModeDebug"

Note that the Jetson graphics driver is very finicky, and doesn’t support a bunch of the extensions and options that Nvidia drivers support on desktop systems.
The graphics driver will also only allow choosing graphics modes that are defined as natively supported in the EDID of the display.


right, i was able to set via shell the display modes with xrand, that is not that bad cause i can control these modes via web-interface.

I want to use the TX2 as a highend broadcast decoder and i needed the 1080i50/i60 mode, p50/60 was not a big problem.
Alternate i think most sport broadcasters uses 1280x720 with p50/p60 instead of 1080i for fast motions transmission.

Thanks guys for helping me out.

Hi garybb,

Interlaced mode is not supported in Tegra SW yet. X11 would not show interlaced mode.

Is this still the case for the latest R28.2?



Yes, interlaced mode is still no enabled on L4T. Could you describe why do you need interlaced mode?

Hi Wayne,

Within a system we are putting together the HDMI output of the TX1/2 will be used as a video source and the customer typically expects the output in 1080i 59.94. We’ll take the HDMI out and convert to an HD-SDI input to an encoder, etc.


Make sure your EDID provides the correct information for the non-interlaced specifications.