11.7 claims held broken packages w/Ubuntu 20.04 and 470

Ubuntu 20.04
NVIDIA-SMI 470.129.06 Driver Version: 470.129.06 CUDA Version: 11.4

Followed instructions from here: CUDA Toolkit 11.7 Update 1 Downloads | NVIDIA Developer

and got this error on last step

The following packages have unmet dependencies:
cuda : Depends: cuda-11-7 (>= 11.7.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

oddly enough nvidia-smi reports cuda version 11.4 but nvcc–version says “not found”

Lenovo Legion Pro 5 Laptop with RTX 3070

“cuda version” reported by nvidia-smi is the myximum supported cuda version of the driver, not the installed cuda toolkit version.

thx, yeah I figured that out later.