4070 ti / Ubuntu 22.10 : drv 525 + cuda 11.5 or drv 530 + cuda 11.7


My current setup is composed of:

  • laptop under Ubuntu 22.10 (Thunderbolt 4)
  • eGPU enclosure (Razer Core)
  • 4070 TI

My initial setup was running using the ubuntu provided drivers: 525-open
I had to add the nvidia.NVreg_OpenRmEnableUnsupportedGpus=1 kernel parameter.
(it does not work with the 525, only with the 525-open)

With this setup:

  • the GPU is properly detected: nvidia-smi and nvidia-settings see the card
  • I can use the GPU under Blender or to run Stable Diffusion inference

The problems began when I tried to use PyTorch and DreamBooth for Stable Diffusion.

My understanding is that to get this to run, I need to upgrade to Cuda 11.6 or 11.7.
Because ubuntu packages only provide Cuda 11.5, I use the installed you provide.

I run the NVidia installer for Cuda-11.7.
It automatically forces me to upgrade to nvidia-driver-530

dkms status
nvidia/530.30.02, 5.19.0-35-generic, x86_64: installed

With the 530 driver, my 4070ti is no longer detected:

  • nvidia-smi returns a “No devices were found”
  • nvidia-settings does not see the card either

I also tried to install cuda 12.1, but ended up with the exact same result.

If I cleanup everything and go back to 525-open and Cuda-11.5 then the GPU is usable again.

What can I do to diagnose the problem and hopefully fix this?

(It seems that Ubuntu 23.04 will have Cuda 11.7 by default, but this is early to switch).



Thank you, it seems to have solved the issue, at least I can go one step further.

Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.